summaryrefslogtreecommitdiff
path: root/libre/kio/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/kio/PKGBUILD')
-rw-r--r--libre/kio/PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/libre/kio/PKGBUILD b/libre/kio/PKGBUILD
index 50adc499d..69c5ea428 100644
--- a/libre/kio/PKGBUILD
+++ b/libre/kio/PKGBUILD
@@ -4,16 +4,17 @@
# Contributor: André Silva <emulatorman@hyperbola.info>
# Contributor: jc_gargma <jc_gargma@iserlohn-fortress.net>
# Maintainer: Andreas Grapentin <andreas@grapentin.org>
+# Contributor: grizzlyuser <grizzlyuser@protonmail.com>
# rational for inclusion in libre:
# - removed support for not freedom-respecting search engines
pkgname=kio
-pkgver=5.68.0
+pkgver=5.69.0
pkgrel=1
pkgrel+=.parabola1
pkgdesc='Resource and network access abstraction'
-pkgdesc+=', without non-privacy search engines'
+pkgdesc+=', only with search engines that claim to respect user privacy and do not serve nonfree JavaScript'
arch=(x86_64)
arch+=(i686 armv7h)
url='https://community.kde.org/Frameworks'
@@ -25,7 +26,7 @@ optdepends=('kio-extras: extra protocols support (sftp, fish and more)' 'kdoctoo
groups=(kf5)
source=("https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"{,.sig})
source+=(duckduckgo_{html,lite}.desktop)
-sha256sums=('9cc2fb2da84d6661a90eac81eb12c2e37921a5c34cbc1975f48d613e5a9d9eef'
+sha256sums=('09e4d37058bb5b5993536ea6b010c605b9d2f732e141e9903e2d5f64fea20de6'
'SKIP'
'31910ab7393e67609f15e04a57f6406f63e6dae58b01bce0787741bc5958f292'
'40466a9dad7075f2525e9e024720da7d7b49a22892b6fca8b81cc0e6408d2f7d')
@@ -34,11 +35,12 @@ validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde
prepare() {
mkdir -p build
- # Removing non-privacy search providers
+ # Removing search providers
cd $pkgname-$pkgver
- rm -v src/urifilters/ikws/searchproviders/{7digital,acronym,amazon{,_mp3},amg,backports,baidu,bing,cia,dbug,deb,duckduckgo{,_info,_shopping},facebook,ecosia,feedster,flickr,flickrcc,google,google_advanced,google_code,google_groups,google_images,google_lucky,google_maps,google_movie,google_news,google_shopping,imdb,jamendo,jeeves,magnatune,metacrawler,msdn,nl-telephone,nl-teletekst,python,rpmfind,tvtome,uspto,vimeo,voila,yahoo,yahoo_image,yahoo_local,yahoo_shopping,yahoo_video,youtube}.desktop
+ rm -v src/urifilters/ikws/searchproviders/*.desktop
# Adding DuckDuckGo HTML and DuckDuckGo Lite
+ # Contributions of other search engines that satisfy pkgdesc are welcome!
cp -v "$srcdir"/duckduckgo_{html,lite}.desktop src/urifilters/ikws/searchproviders
}