summaryrefslogtreecommitdiff
path: root/libre/kernel26-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/kernel26-libre/PKGBUILD')
-rw-r--r--libre/kernel26-libre/PKGBUILD65
1 files changed, 25 insertions, 40 deletions
diff --git a/libre/kernel26-libre/PKGBUILD b/libre/kernel26-libre/PKGBUILD
index a805817b1..ddbd74bc7 100644
--- a/libre/kernel26-libre/PKGBUILD
+++ b/libre/kernel26-libre/PKGBUILD
@@ -3,58 +3,34 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): fauno <fauno@kiwwwi.com.ar>
pkgbase="kernel26-libre"
-#pkgname=('kernel26-libre' 'kernel26-libre-headers' 'kernel26-libre-manpages' 'kernel26-libre-docs') # Build stock -ARCH kernel
-pkgname=('kernel26-libre' 'kernel26-libre-headers' 'kernel26-libre-docs') # Build stock -ARCH kernel
-# pkgname=kernel26-custom # Build kernel with a different name
+pkgname=('kernel26-libre' 'kernel26-libre-headers' 'kernel26-libre-docs') # Build stock -LIBRE kernel
_kernelname=${pkgname#kernel26-libre}
-_basekernel=2.6.36
-pkgver=${_basekernel}.3
-pkgrel=2
+_basekernel=2.6.37
+pkgver=${_basekernel}
+pkgrel=4
makedepends=('xmlto' 'docbook-xsl')
-_patchname="patch-${pkgver}-${pkgrel}-ARCH"
+_patchname="patch-${pkgver}-${pkgrel}-LIBRE"
arch=(i686 x86_64)
license=('GPL2')
url="http://linux-libre.fsfla.org/"
-source=(http://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_basekernel.tar.bz2
- ftp://ftp.archlinux.org/other/kernel26/${_patchname}.bz2
+install=kernel26.install
+source=(http://linux-libre.fsfla.org/pub/linux-libre/releases/2.6.37-libre/linux-2.6.37-libre.tar.bz2
+ http://repo.parabolagnulinux.org/other/kernel26/${_patchname}.bz2
# the main kernel config files
config.i686 config.x86_64
- logo_linux_clut224.ppm
- logo_linux_mono.pbm
- logo_linux_vga16.ppm
- http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre1/deblob-${_basekernel}
- http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre1/deblob-check
- http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre1/deblob-main
# standard config files for mkinitcpio ramdisk
- kernel26.preset)
-md5sums=('61f3739a73afb6914cb007f37fb09b62'
- '02c08947ae93786a2ed6d276b09182ab'
- '9ffc3784807cb0c0c86f2a26e6872dbc'
- '01664330dd5c3fba0ff317ba779a8955'
- '071d4939e9ef4256e4c027ef3c864903'
- '2ae9ef17f45b39ff9e6e172c0c97d263'
- '96c2ae40e3b1cdd90fe7e6dba8078922'
- '6f4ad7c73300570046799642daf60492'
- 'a68a65f4f45efb17c0253ee61c9bc363'
- '3b67aa4b9ec4bd192301635aa4646d2b'
- '25584700a0a679542929c4bed31433b6')
+ kernel26.preset
+ kernel26.install)
build() {
cd ${srcdir}/linux-$_basekernel
- # Add -ARCH patches
- # See http://projects.archlinux.org/linux-2.6-ARCH.git/
+ # Add -LIBRE patches
+ # See http://projects.parabolagnulinux.org/linux-libre-2.6-LIBRE.git/
patch -Np1 -i ${srcdir}/${_patchname} || return 1
- msg "Setting Freedo as boot logo..."
- cp --remove-destination $srcdir/logo*.p{p,b}m ./drivers/video/logo/
-
cat $srcdir/config.$CARCH > ./.config # simpler
- msg "Deblobing..."
- chmod +x ${srcdir}/deblob-* || return 1
- PYTHON=false ${srcdir}/deblob-${_basekernel} || return 1
-
- for this_doesnt_build in CONFIG_RTL8192SU CONFIG_E100 CONFIG_WLAGS49_H2 CONFIG_WLAGS49_H25; do
+ for this_doesnt_build in CONFIG_WLAGS49_H2 CONFIG_WLAGS49_H25; do
sed -i "s|^${this_doesnt_build}=.*|# ${this_doesnt_build} is not set|g" ./.config
done
@@ -66,9 +42,6 @@ build() {
sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
fi
- msg "Saving deblobbed version..."
- tar -czf ${startdir}/linux-${_basekernel}-deblobbed.tar.gz .
-
# get kernel version
make prepare
# load configuration
@@ -284,3 +257,15 @@ find $pkgdir -type d -exec chmod 755 {} \;
# remove a file already in kernel26 package
rm -f $pkgdir/usr/src/linux-$_kernver/Documentation/DocBook/Makefile
}
+md5sums=('3e80c55a0927b4439f3aad4f973f05cc'
+ 'e9ad91e5f11d71894adb624267a65eb6'
+ 'e0adf1214045db007c5a4308325786d0'
+ '855c90dd52b1deef44a70ab3b2ebde1e'
+ '25584700a0a679542929c4bed31433b6'
+ '00122850abe36601f3be09f99e0ac0ab')
+md5sums=('3e80c55a0927b4439f3aad4f973f05cc'
+ 'b9eecbe905cc8db8dc1b408ae5e471da'
+ 'ab3f8671ab29aeb29d8c8dc725894632'
+ '244c939a8159a78d124227d2ab2116a2'
+ '25584700a0a679542929c4bed31433b6'
+ '1b70cfc782e18bbb9467000f83110ce0')