summaryrefslogtreecommitdiff
path: root/libre/jami-qt/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/jami-qt/PKGBUILD')
-rw-r--r--libre/jami-qt/PKGBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/libre/jami-qt/PKGBUILD b/libre/jami-qt/PKGBUILD
new file mode 100644
index 000000000..abccb3a36
--- /dev/null
+++ b/libre/jami-qt/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer (arch): Bruno Pagani <archange@archlinux.org>
+
+
+# parabola changes and rationale:
+# - no changes
+# - temporary 'jami-qt' build without qt6-webengine
+# the next jami release should have this VCS change;
+# so the arch pckage will be FDSG-fit then
+# - NOTE: this is built from VCS; but so was the
+# latest arch package - AFAIK, this should be
+# named 'jami-qt-git' - it is a one-time
+# blacklist replacement though; so it is less
+# troublesome to keep the arch pkgname
+# - NOTE: jami-{daemon,libclient,qt} versions are all tightly coupled,
+# even at the VCS level
+# implied build order: jami-daemon <- jami-libclient <- jami-qt
+
+
+pkgname=jami-qt
+pkgver=20220505
+pkgrel=1
+pkgrel+=.parabola1
+pkgdesc="Free and universal communication platform which preserves the users’ privacy and freedoms (Qt client)"
+arch=(x86_64)
+url="https://jami.net"
+license=(GPL3)
+groups=(jami)
+depends=(jami-libclient glib2 gdk-pixbuf2 libnm libnotify qrencode
+ qt6-declarative qt6-multimedia qt6-networkauth qt6-svg
+ qt6-5compat qt6-webengine qt6-webchannel)
+depends=( ${depends[*]/qt6-webengine/} )
+makedepends=(git cmake python qt6-tools)
+replaces=(jami-gnome)
+conflicts=(jami-gnome)
+_commit=dd0dc87a0110b55f7f5ee450e13520c683e78650
+source=(git+https://git.jami.net/savoirfairelinux/jami-client-qt.git#commit=${_commit})
+md5sums=(SKIP)
+
+# pkgver() {
+# cd jami-client-qt
+# TZ=UTC git show -s --pretty=%cd --date=format-local:%Y%m%d HEAD
+# }
+
+build() {
+ cmake -B build -S jami-client-qt \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -DWITH_WEBENGINE=false \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}