summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD30
1 files changed, 29 insertions, 1 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index fe53ac039..fffe5070b 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -27,6 +27,9 @@
# - Modify the addons pages to use GNU IceCat plugins sources, rather
# than addons.mozilla.org, which hosts non-free addons
# - Disable EME, which is implemented via the non-free libWideVine CDM
+# - Disable Normandy that let Mozilla push messages with recommendations
+# of nonfree software
+# - Make Remote Settings work completely offline using local data
# - Rebrand to Iceweasel, per the mozilla trademark policy,
# due to these FSDG changes
#
@@ -74,6 +77,7 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
libre.patch
libre-searchengines.patch
+ libre-0001-always-sync-remote-settings-with-local-dump.patch
vendor.js.in)
source_armv7h=(arm.patch
build-arm-libopus.patch)
@@ -286,11 +290,18 @@ END
export QUILT_PATCHES="${brandingsrcdir}"/patches
export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
export QUILT_DIFF_ARGS='--no-timestamps'
+ export QUILT_PC=$srcdir/.pc
quilt push -av
## searchengines ##
+ # Load custom searchplugins
+ # FIXME: no longer applicable - replace with (broken) replacement fo libre/mozilla-searchplugins
+ # https://git.parabola.nu/packages/iceweasel.git/tree/branding-dev-build/mozilla-searchplugins?h=68.0
+# rm -rvf -- browser/components/search/searchplugins/{*.xml,images/}
+# cp -av -- /usr/lib/mozilla/searchplugins/* browser/components/search/searchplugins/
+
# Patch search-engines config
# FIXME: custom searchplugins ID per new format above ("ddg" is standard)
# browser/components/search/extensions/<ID>/
@@ -333,6 +344,23 @@ END
## libre patching ##
+ # Remove remaining non-free bits
+ # Remove test-related networking dumps, because they contain code from
+ # some Amazon webpage with no clear licensing, thus nonfree.
+ # Also they interfere with checking of Remote Settings patching done later,
+ # because communication with RS server has been captured in them too.
+ rm python/mozperftest/mozperftest/system/example.zip
+ rm testing/mozbase/mozproxy/tests/files/mitm5-linux-firefox-amazon.zip
+
+ # Disable/neutralize Remote Settings (as best we can)
+ echo "applying libre-0001-always-sync-remote-settings-with-local-dump.patch"
+ patch -Np1 --no-backup-if-mismatch -i ../libre-0001-always-sync-remote-settings-with-local-dump.patch
+
+ # Check Remote Settings patched completely by
+ # libre-0001-always-sync-remote-settings-with-local-dump.patch
+ local settings_server='firefox.settings.services.mozilla.com'
+ ! grep -qr $settings_server || { echo 'Remote Settings patching needs rework'; return 1; }
+
# Disable various components at the source level
sed -i 's/;1/;0/' toolkit/components/telemetry/components.conf
sed -Ei 's/((MOZ_SERVICES_HEALTHREPORT|MOZ_NORMANDY).+)True/\1False/' browser/moz.configure
@@ -354,7 +382,7 @@ END
# Patch and remove anything that's left
echo "applying libre.patch"
- patch -Np1 -i "${srcdir}"/libre.patch
+ patch -Np1 --no-backup-if-mismatch -i "${srcdir}"/libre.patch
}
build() {