summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD54
1 files changed, 19 insertions, 35 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 88c99a7ba..b9682c814 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -40,7 +40,7 @@
pkgname=iceweasel
replaces=('firefox')
epoch=1
-pkgver=70.0.1
+pkgver=71.0
pkgrel=1
pkgrel+=.parabola1
_brandingver=70.0
@@ -65,24 +65,20 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
- no-relinking.patch
0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop)
source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
- firefox-70.0-update-bindgen.patch
firefox-70.0-add-distro.patch
libre.patch
libre-searchengines.patch)
-sha256sums=('f2e9bb26af7682b31e82fdfc3a4b3e04fd1caa8b004469ea608185d33e35691b'
+sha256sums=('78304cd58229e7103b56b34718aad051c9a4db30c266512a64f501ba58da7fbe'
'SKIP'
- '2dc9d1aa5eb7798c89f46478f254ae61e4122b4d1956d6044426288627d8a014'
- 'ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894'
- 'e439117380218898cd5c60a8da8947847efbd0fe64cc06b129d6ca20a392cb3d'
+ '5f7ac724a5c5afd9322b1e59006f4170ea5354ca1e0e60dab08b7784c2d8463c'
+ 'f573d00835afe066ef1887bfea35099933ee07aeadc4c0d603972127e600cfc4'
'e90956067d8549f02864d612369ed8714d7173f0ee07bbfb4374a7323b4a733e'
'SKIP'
- 'bde80a158f42f6afd01d9f3ce1ff9c8ecb89db96b6b7398f2acfb03436234eeb'
'41ab298519dfdf86e1599990cd2a2e4d939a2a1d77de829caa0593d0d2e8f0e8'
- '783e1b7c2f6f8719cc8a0751aacc823a5029c2326ac0b5ff7c659d831e286387'
+ '698e73d66bb94d82cc11bc0a56cb59455b3b0b51798a48ad7a7b4c429104647e'
'dfed11d97f1d4198a3dc608be159b6b53a11054f376cdb73bb0fe9a487ae9418')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
validpgpkeys+=('BFA8008A8265677063B11BF47171986E4B745536') # Andreas Grapentin
@@ -91,15 +87,9 @@ prepare() {
mkdir mozbuild
cd firefox-$pkgver
- # Avoid relinking during buildsymbols
- patch -Np1 -i ../no-relinking.patch
-
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1583471
- patch -Np1 -i ../firefox-70.0-update-bindgen.patch
-
# https://bugzilla.mozilla.org/show_bug.cgi?id=1212502
patch -Np1 -i ../firefox-70.0-add-distro.patch
@@ -139,6 +129,7 @@ ac_add_options --disable-crashreporter
ac_add_options --disable-gconf
ac_add_options --disable-updater
ac_add_options --disable-tests
+ac_add_options --disable-eme
END
if [[ $CARCH = arm* ]]; then
@@ -257,7 +248,7 @@ END
xvfb-run -a -n 92 -s "-screen 0 1600x1200x24" \
./mach python build/pgo/profileserver.py
- if ! compgen -G '*.profraw' >&2; then
+ if [[ ! -s merged.profdata ]]; then
error "No profile data produced."
return 1
fi
@@ -274,7 +265,7 @@ END
cat >.mozconfig ../mozconfig - <<END
ac_add_options --enable-lto=cross
ac_add_options --enable-profile-use=cross
-ac_add_options --with-pgo-profile-path=${PWD@Q}
+ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
END
./mach build
@@ -290,7 +281,6 @@ package() {
cd firefox-$pkgver
DESTDIR="$pkgdir" ./mach install
- find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
local vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
install -Dvm644 /dev/stdin "$vendorjs" <<END
@@ -328,12 +318,6 @@ pref("geo.enabled", false);
// Make sure that the request URL of the GeoLocation backend is empty
pref("geo.wifi.uri", "");
-// Disable Freedom Violating DRM Feature
-pref("browser.eme.ui.enabled", false);
-// EME
-pref("media.eme.enabled", false);
-pref("media.eme.apiVisible", false);
-
// Google Widevine DRM
// https://blog.mozilla.org/futurereleases/2016/04/08/mozilla-to-test-widevine-cdm-in-firefox-nightly/
// https://wiki.mozilla.org/QA/Widevine_CDM
@@ -342,9 +326,8 @@ pref("media.gmp-widevinecdm.visible", false);
pref("media.gmp-widevinecdm.enabled", false);
pref("media.gmp-widevinecdm.autoupdate", false);
-// Default to classic view for about:newtab
-pref("browser.newtabpage.enhanced", false);
-pref("browser.newtabpage.activity-stream.enabled", false);
+// Default sites for about:newtab
+pref("browser.newtabpage.activity-stream.default.sites", "https://wiki.parabola.nu/,https://labs.parabola.nu/,https://www.gnu.org/,https://libreplanet.org/,https://www.wikipedia.org/");
// Poodle attack
pref("security.tls.version.min", 1);
@@ -620,6 +603,15 @@ pref("security.sandbox.content.syscall_whitelist", "16");
// https://labs.parabola.nu/issues/2409
pref("extensions.htmlaboutaddons.discover.enabled", false);
pref("extensions.htmlaboutaddons.recommendations.enabled", false);
+
+// Disable "Recommend extensions as you browse" in about:preferences#general
+pref("browser.newtabpage.activity-stream.asrouter.userprefs.cfr.addons", false);
+
+// URL for 'Find more extensions / themes' in about:addons page
+pref("extensions.getAddons.search.browseURL", "https://www.parabola.nu/packages/?q=%TERMS%");
+
+// Make extensions work on Mozilla domains
+pref("extensions.webextensions.restrictedDomains", "");
END
local distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
@@ -661,14 +653,6 @@ END
if [[ -e $nssckbi ]]; then
ln -srfv "$pkgdir/usr/lib/libnssckbi.so" "$nssckbi"
fi
-
- if [[ -f "$startdir/.crash-stats-api.token" ]]; then
- find . -name '*crashreporter-symbols-full.zip' -exec \
- "$startdir/upload-symbol-archive" "$startdir/.crash-stats-api.token" {} +
- else
- find . -name '*crashreporter-symbols-full.zip' -exec \
- cp -fvt "$startdir" {} +
- fi
}
# vim:set sw=2 et: