summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD37
1 files changed, 5 insertions, 32 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index fffe5070b..1f0960d57 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -296,36 +296,9 @@ END
## searchengines ##
- # Load custom searchplugins
- # FIXME: no longer applicable - replace with (broken) replacement fo libre/mozilla-searchplugins
- # https://git.parabola.nu/packages/iceweasel.git/tree/branding-dev-build/mozilla-searchplugins?h=68.0
-# rm -rvf -- browser/components/search/searchplugins/{*.xml,images/}
-# cp -av -- /usr/lib/mozilla/searchplugins/* browser/components/search/searchplugins/
-
- # Patch search-engines config
- # FIXME: custom searchplugins ID per new format above ("ddg" is standard)
- # browser/components/search/extensions/<ID>/
-# local remove_engines_sed='s|.*oogle.*| "ddg", "duckduckgo-html", "duckduckgo-lite", "internet-archive", "parabola-labs", "parabola-packages", "parabola-wiki-en", "searx", "wikipedia", "yacy"|g'
- local remove_engines_sed='s|.*oogle.*| "ddg", "wikipedia"|g'
- echo "applying libre-searchengines.patch"
- patch -Np1 -i "${srcdir}"/libre-searchengines.patch
- sed -i "${remove_engines_sed}" list.json
- sed -i 's|https://duckduckgo.com/|https://html.duckduckgo.com/html/|' ddg/manifest.json
-
pushd browser/components/search/extensions
- # replace default searchplugins
- # FIXME: no longer applicable - replace with (broken) replacement fo libre/mozilla-searchplugins
- # https://git.parabola.nu/packages/iceweasel.git/tree/branding-dev-build/mozilla-searchplugins?h=68.0
-# rm -rvf -- browser/components/search/searchplugins/{*.xml,images/}
-# cp -av -- /usr/lib/mozilla/searchplugins/* browser/components/search/searchplugins/
- # TODO: replacement implementation for above - see analogous changes in libre/icecat/PKGBUILD
-# cp -av -- /usr/share/mozilla/searchplugins/* .
- find -mindepth 1 -maxdepth 1 \
- -not -name ddg \
- -not -name wikipedia \
- -not -name list.json \
- -exec rm -rf {} \;
+ sed -i 's|https://duckduckgo.com/|https://html.duckduckgo.com/html/|' ddg/manifest.json
# Removing URL parameters that let DuckDuckGo know the place in UI
# the search was ran from (like address bar, context menu, etc.)
@@ -334,10 +307,10 @@ END
! diff manifest.json.tmp ddg/manifest.json > /dev/null
mv manifest.json.tmp ddg/manifest.json
- # Sanity-check search-engines patching
- local removed_engines_regex='Bing|Google|Seznam|Twitter|Yahoo|Yandex|Яндекс|amazon|bing|google|ebay|twitter'
- local engines_err_msg="search-engines patch needs re-working"
- ! grep -E ${removed_engines_regex} list.json > /dev/null || ! echo "${engines_err_msg}"
+ find -mindepth 1 -maxdepth 1 \
+ -not -name ddg \
+ -not -name wikipedia \
+ -exec rm -frv {} \;
popd