summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD36
1 files changed, 18 insertions, 18 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 42c0fdbef..eaf5ed6bf 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -47,10 +47,10 @@
pkgname=iceweasel
epoch=1
-pkgver=90.0
+pkgver=91.0
pkgrel=1
pkgrel+=.parabola1
-_brandingver=87.0-1
+_brandingver=91.0-1
pkgdesc="Standalone web browser derived from Mozilla Firefox"
arch=(x86_64)
arch+=(i686 armv7h)
@@ -79,26 +79,26 @@ source=(https://archive.mozilla.org/pub/firefox/releases/${pkgver}/source/firefo
0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop)
source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}.branding.tar.xz{,.sig}
- 9001-always-sync-remote-settings-with-local-dump.patch
- 9002-preference-defaults.patch
- 9003-misc-libre.patch
+ 9001-FSDG-always-sync-remote-settings-with-local-dump.patch
+ 9002-FSDG-preference-defaults.patch
+ 9003-FSDG-misc.patch
process-json-files.py
vendor.js.in)
source_armv7h=(arm.patch
build-arm-libopus.patch)
source_i686=('avoid-libxul-OOM-python-check.patch'
'rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums=('43a943e7d7660c6d7f5b41c95b344b7fd6a4a88ad0bb45dbd844b372ea60d58b'
+sha256sums=('2a4d1f788ab77f68380d4e6ab0b36bd1efd1a4ac9e9c6d10e39377894c077901'
'SKIP'
- '7e7435e8171426e87a84cecf9eb017cb969c9c85d973feb78c1e05771972b6e9'
+ '138b972a40a74104791783167770c4a01e62cce00bb9cc75119e152f9ea9f14d'
'9cdc2602661717712092d28bb494e5b48e518cb930898aca85eaf21f91f7ef58')
-sha256sums+=('e0a0c7434a057dffdce49bb3e5f53fa190aef24f2666cdc50262170df8fec94f'
+sha256sums+=('e36e6c1f214affc8884daf0f13c5b2d3aff28fcce809d06ca79ee44e3b68d1a2'
'SKIP'
- '798d5d167ff4c8030aebd9dbc931df80c34f08a6aed718b878b064e47e4b4f16'
- 'f6114bfe02716442658874e80e553d1cd5fadf4626b461fb94cfb2623cd34b7b'
+ '6ebbf18792cb57067f500fd4575c341d4708c5c0a232d676471f87dfa590621b'
+ 'afeaeb6e9a6af901b57e25d85014e5c792efe4ff9dabb58663377f487b9d2887'
'39e3a5e1ad137e21f842a44d7e3bd24050292d2b41fe59b4e7c7dfed52a195dd'
- '90e710662f06c619de8752b088ce56bf3779f24168387b1c18e733391bedd143'
- '4e4ef3f5643da6a23b05de9266c1b2c5310483638b23670944374e12aa446a35')
+ '9386f1c50506cd20ab6d212335d5e4417faeb2aea371dd46f2d107d171e80b83'
+ 'c93ce98e1cb64033079343ff1f3037fab6a3bc6d3eb5bc14c5edb70e2d45965d')
sha256sums_i686=('2f0c81a38c4578f68f5456b618fe84a78974072821488173eb55e0e72287e353'
'10c5276eab2e87f400a6ec15d7ffbef3b0407ee888dea36f1128927ca55b9041')
sha256sums_armv7h=('bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
@@ -356,8 +356,8 @@ END
rm testing/mozbase/mozproxy/tests/files/mitm5-linux-firefox-amazon.zip
# Disable/neutralize Remote Settings (as best we can)
- echo "applying 9001-always-sync-remote-settings-with-local-dump.patch"
- patch -Np1 --no-backup-if-mismatch -i ../9001-always-sync-remote-settings-with-local-dump.patch
+ echo "applying 9001-FSDG-always-sync-remote-settings-with-local-dump.patch"
+ patch -Np1 --no-backup-if-mismatch -i ../9001-FSDG-always-sync-remote-settings-with-local-dump.patch
# Verify Remote Settings patching
local settings_server='firefox.settings.services.mozilla.com'
@@ -372,12 +372,12 @@ END
python ../process-json-files.py "${srcdir}"/firefox-${pkgver} "${brandingsrcdir}"
- echo "applying 9002-preference-defaults.patch"
- patch -Np1 --no-backup-if-mismatch -i "${srcdir}"/9002-preference-defaults.patch
+ echo "applying 9002-FSDG-preference-defaults.patch"
+ patch -Np1 --no-backup-if-mismatch -i "${srcdir}"/9002-FSDG-preference-defaults.patch
# Remove remaining non-free bits
- echo "applying 9003-misc-libre.patch"
- patch -Np1 --no-backup-if-mismatch -i "${srcdir}"/9003-misc-libre.patch
+ echo "applying 9003-FSDG-misc.patch"
+ patch -Np1 --no-backup-if-mismatch -i "${srcdir}"/9003-FSDG-misc.patch
}
build() {