summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 341c954c2..9ab4537ea 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -16,8 +16,8 @@ _pgo=true
# We're getting this from Debian Experimental
_debname=iceweasel
-_debver=40.0.3
-_debrel=deb3
+_debver=41.0
+_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -30,7 +30,7 @@ pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based o
arch=(i686 x86_64)
license=(MPL GPL LGPL)
depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell icu=55.1 libevent libvpx=1.4.0 libxt mime-types mozilla-common nss sqlite startup-notification)
-makedepends=(autoconf2.13 diffutils gst-plugins-base-libs imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa mozilla-searchplugins pkg-config python2 quilt unzip yasm zip)
+makedepends=(autoconf2.13 diffutils gconf gst-plugins-base-libs imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa mozilla-searchplugins pkg-config python2 quilt unzip yasm zip)
options=(!emptydirs !makeflags debug)
if $_pgo; then
makedepends+=(xorg-server-xvfb)
@@ -43,7 +43,7 @@ url="http://packages.debian.org/experimental/${pkgname}"
install=$pkgname.install
replaces=("${pkgname}-libre" 'firefox')
conflicts=("${pkgname}-libre")
-source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
+source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.xz"
"$_debrepo/`debfile $_debname`_$_debver-${_debrel#deb}.debian.tar.xz"
mozconfig
libre.patch
@@ -53,15 +53,15 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
$pkgname-install-dir.patch
vendor.js
$pkgname-fixed-loading-icon.png)
-sha256sums=('2a2ded339bf491c4072fdcdc79cdc906733deffb8bcfa1d4fd9243e7f4ff9ee9'
- '3098ccfab025999b166876fce8fda2d52fbd8ebd32d0a872a86238aa6c5a2e24'
+sha256sums=('2274baa823b5de03732e120f3278c81f6fdc5bb67ab3b219903f89206487a256'
+ '991cc1e92a9d579b2bb7a2091f5aafc29b2b7bf75e97e428343dfc38ea5003c6'
'8e0b2aa899f9c71dfabf61e8e3427bda9a6ef76330bda4428d1badddcfc331a5'
- '1811eec7a02411295affc6ee66e3e4b9fd636b0bfbd313ce2a132beb124612d8'
+ '49566ee824f0b40d4eb90c20bc23dc2a4caca47ceee4554936d020575dda0598'
'93e3001ce152e1d142619e215a9ef07dd429943b99d21726c25da9ceb31e31cd'
'56eba484179c7f498076f8dc603d8795e99dce8c6ea1da9736318c59d666bff6'
'2257dc69886bd0b72c48675a27c3a88b9cf6b598252c9e9f1c99763180684fc3'
'3aea6676f1e53a09673b6ae219d281fc28054beb6002b09973611c02f827651d'
- '0171656480113c6fabfdf5b14effe4ac67fda667682eb692badac81562afa696'
+ 'b078b1abbbcda77a0d116878b999496e65f6cff9cf60e0fbb7ce6977f767f1de'
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213')
prepare() {
@@ -74,9 +74,6 @@ prepare() {
mv debian "$srcdir/$DEBIAN_BUILD"
cd "$srcdir/$DEBIAN_BUILD"
- # Doesn't apply and seems unimportant
- rm -v debian/patches/l10n/Place-google-and-gmail-before-yandex.patch || true
-
quilt push -av
# Put gnu_headshadow.png and drm-free.png in the source code