summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD29
1 files changed, 22 insertions, 7 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 2248eb22d..cea3611ae 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -20,20 +20,20 @@
# parabola changes and rationale:
# - rebranded to iceweasel
-# - added to makedepends: mozilla-searchplugins, quilt, libxslt, imagemagick
-# - removed from makedepends: mercurial
-# - using tarball instead of repository
-# - added replaces and conflicts for firefox
# - removed google api keys and usage
+# - using tarball instead of repository
+# - added makedepends: mozilla-searchplugins, quilt, libxslt, imagemagick
+# - removed makedepends: mercurial
+# - added replaces, conflicts and provides: firefox
_pkgname=firefox
pkgname=iceweasel
epoch=1
pkgver=58.0
-pkgrel=2
+pkgrel=4
_bver=58.0
_brel=1
-pkgdesc="Libre standalon web browser based on Mozilla Firefox"
+pkgdesc="Libre standalone web browser based on Mozilla Firefox"
arch=(x86_64 i686 armv7h)
license=(MPL GPL LGPL)
url="https://wiki.parabola.nu/$pkgname"
@@ -51,7 +51,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
options=(!emptydirs !makeflags !strip)
replaces=("$_pkgname")
conflicts=("$_pkgname")
-_parabolarepo=https://repo.parabola.nu/other/iceweasel
+provides=("$_pkgname")
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
$pkgname.desktop
$pkgname-install-dir.patch no-crmf.diff
@@ -114,6 +114,21 @@ ac_add_options --disable-stylo
ac_add_options --disable-eme
END
+ if [[ "$CARCH" == arm* ]]; then
+ sed -i \
+ -e '/enable-gold/s/^/#/' \
+ -e '/enable-pie/s/^/#/' \
+ -e '/enable-optimize/d' \
+ .mozconfig
+
+ cat >> .mozconfig << END
+ac_add_options --disable-webrtc
+ac_add_options --disable-elf-hack
+ac_add_options --disable-stylo
+ac_add_options --enable-optimize="-g -O2 -fno-schedule-insns"
+END
+ fi
+
# perform rebranding
local brandingdir="$srcdir/$pkgname-$_bver"
mkdir -v browser/branding/$pkgname