summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--[-rwxr-xr-x]libre/iceweasel-libre/PKGBUILD61
1 files changed, 36 insertions, 25 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index 56f1e4dfa..cbf402860 100755..100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -14,14 +14,14 @@ _pgo=false
# We're getting this from Debian Experimental
_debname=iceweasel
-_debver=17.0.1
+_debver=18.0
_debrel=1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
_pkgname=iceweasel
pkgname=iceweasel-libre
-pkgver=${_debver}.${_debrel}
+pkgver=$_debver.$_debrel
pkgrel=4
if [ -z "$pkgname" ]; then pkgname=$_pkgname; fi
@@ -32,35 +32,38 @@ fi
pkgdesc="A libre version of Debian Iceweasel, the Browser based on Mozilla Firefox."
arch=('i586' 'i686' 'x86_64' 'mips64el')
license=('GPL2' 'MPL' 'LGPL')
-depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'mozilla-searchplugins' 'nss>=3.13.1' 'sqlite3' 'startup-notification')
-makedepends=( 'autoconf2.13' 'diffutils' 'imagemagick' 'libidl2' 'librsvg' 'libxslt' 'mesa' 'pkg-config' 'python2' 'quilt' 'unzip' 'wireless_tools' 'zip')
+depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'mozilla-searchplugins' 'nss>=3.14.1' 'sqlite3' 'startup-notification')
+makedepends=( 'autoconf2.13' 'diffutils' 'imagemagick' 'libidl2' 'librsvg' 'libxslt' 'mesa' 'pkg-config' 'python2' 'quilt' 'unzip' 'zip')
[ "$CARCH" != "mips64el" ] && makedepends+=('yasm')
if $_pgo; then
makedepends+=('xorg-server-xvfb')
options=(!ccache)
fi
+optdepends=('networkmanager: Location detection via available WiFi networks')
url="http://www.geticeweasel.org/"
install=iceweasel.install
-source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.bz2"
- "${_debrepo}/`debfile ${_debname}`_${_debver}-${_debrel}.debian.tar.gz"
+source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
+ "$_debrepo/`debfile $_debname`_$_debver-$_debrel.debian.tar.gz"
mozconfig
mozconfig.pgo
- xulrunner-copy-stub.patch
libre.patch
+ iceweasel.desktop
iceweasel-install-dir.patch
vendor.js
shared-libs.patch
+ bug677092.patch
Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch)
-md5sums=('37b9b7eafc8affa9b8a5942f8ff19f8f'
- '1bbf435ff33f9824de23c0b13fbfb452'
- 'eab149c1994ab14392e55af3abb08e80'
+md5sums=('366e1e4847d7e00eba77ee5a4be0d3db'
+ '6a571d3a3b355c331f67d57702f4fccf'
+ '619e8f7c8596838a7daf2b7ce2e54cd3'
'ac29b01c189f20abae2f3eef1618ffc0'
- 'a485a2b5dc544a8a2bd40c985d2e5813'
- 'c8040002668fae7d1b950833bae51607'
+ '7d16be01a546d7733ab28db980d230f3'
+ '2823e0ecdefc16b590a9997f9228924a'
'abf5ecb74caa857abb42bcfbb3442d9c'
'0d053487907de4376d67d8f499c5502b'
'52e52f840a49eb1d14be1c0065b03a93'
+ 'e1204e0be964b6964ebfb6467e05141f'
'65f68090d2a69b467bd2707d0c4ea3bd')
if [ "$_pkgname" != "$pkgname" ]; then
@@ -69,28 +72,37 @@ if [ "$_pkgname" != "$pkgname" ]; then
fi
build() {
+ # WebRTC build tries to execute "python" and expects Python 2
+ # Workaround taken from chromium PKGBUILD on Archlinux
+ mkdir "$srcdir/python2-path"
+ ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+ export PATH="$srcdir/python2-path:$PATH"
+
export QUILT_PATCHES=debian/patches
export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
export QUILT_DIFF_ARGS='--no-timestamps'
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$_pkgname"
export PYTHON="/usr/bin/python2"
export DEBIAN_BUILD="mozilla-release"
- mv debian "${srcdir}/${DEBIAN_BUILD}"
- cd "${srcdir}/${DEBIAN_BUILD}"
+ mv debian "$srcdir/$DEBIAN_BUILD"
+ cd "$srcdir/$DEBIAN_BUILD"
# Doesn't apply and seems unimportant
rm -v debian/patches/l10n/Place-google-and-gmail-before-yandex.patch || true
- # This patch doesn't works in some parts due that has patches for others locales languages, source code doesn't has it
+ # This patch doesn't works in some parts due that has patches for others locales languages, source code hasn't it
rm -v debian/patches/debian-hacks/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch || true
quilt push -a
patch -Np1 -i "$srcdir/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch" # Adding fixed Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
- patch -Np1 -i "$srcdir/xulrunner-copy-stub.patch" # small fix
patch -Np1 -i "$srcdir/libre.patch"
patch -Np1 -i "$srcdir/shared-libs.patch"
+
+ # Back out https://bugzilla.mozilla.org/show_bug.cgi?id=677092
+ # in order to fix https://bugzilla.mozilla.org/show_bug.cgi?id=818468
+ patch -Rp1 -i ../bug677092.patch
cp "$srcdir/mozconfig" .mozconfig # Load our build config, disable SafeSearch
@@ -98,7 +110,7 @@ build() {
cat "$srcdir/mozconfig.pgo" >> .mozconfig
fi
-# From js on abslibre-mips64el.git
+ # From js on abslibre-mips64el.git
if [ "$CARCH" = "mips64el" ]; then
msg "Force disabling JIT."
sed -ri 's/#define ENABLE_(JIT|ASSEMBLER) 1/#define ENABLE_\1 0/' \
@@ -113,7 +125,7 @@ build() {
sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
browser/base/Makefile.in
- # This is a bug, we should fix it.
+ # This is a bug, we should fix it
if [ "$CARCH" = "mips64el" ]; then
# Fix MIPS N32 support.
sed -i 's/defined(_ABIO32)/(defined(_ABIO32) || defined(_ABIN32))/' \
@@ -137,24 +149,23 @@ build() {
}
package() {
- cd "${srcdir}/${DEBIAN_BUILD}"
+ cd "$srcdir/$DEBIAN_BUILD"
make -j1 -f client.mk DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir"/vendor.js "$pkgdir/usr/lib/$_pkgname/defaults/preferences/vendor.js"
+ install -Dm644 "$srcdir/vendor.js" "$pkgdir/usr/lib/$_pkgname/defaults/preferences"
- # I don't even know why we're hitting the objdir, and ConnOS didn't.
+ # I don't even know why we're hitting the objdir, and ConnOS didn't
_brandingdir=debian/branding
brandingdir=moz-objdir/$_brandingdir
icondir="$pkgdir/usr/share/icons/hicolor"
for i in 16x16 32x32 48x48 64x64; do
install -Dm644 "$brandingdir/default${i/x*/}.png" "$icondir/$i/apps/$_pkgname.png"
done
- install -Dm644 "$brandingdir/mozicon128.png" "$icondir/128x128/apps/$_pkgname.png"
+ install -Dm644 "$brandingdir/mozicon128.png" "$icondir/128x128/apps/$_pkgname.png"
install -Dm644 "$_brandingdir/iceweasel_icon.svg" "$icondir/scalable/apps/$_pkgname.svg"
- install -d "$pkgdir/usr/share/applications"
- install -m644 debian/iceweasel.desktop "$pkgdir/usr/share/applications"
- #install -m644 debian/iceweasel-safe.desktop "$pkgdir/usr/share/applications"
+ install -d "$pkgdir/usr/share/applications"
+ install -m644 "$srcdir/iceweasel.desktop" "$pkgdir/usr/share/applications"
rm -rf "$pkgdir/usr/lib/$_pkgname/"{dictionaries,hyphenation,searchplugins,plugins}
ln -sf /usr/share/hunspell "$pkgdir/usr/lib/$_pkgname/dictionaries"