summaryrefslogtreecommitdiff
path: root/libre/icedove-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/icedove-libre/PKGBUILD')
-rw-r--r--libre/icedove-libre/PKGBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/libre/icedove-libre/PKGBUILD b/libre/icedove-libre/PKGBUILD
index 237d617f9..8473cadd8 100644
--- a/libre/icedove-libre/PKGBUILD
+++ b/libre/icedove-libre/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer : Márcio Silva <coadde@lavabit.com>
# Maintainer : André Silva <emulatorman@lavabit.com>
-# We're getting this from Debian Experimental
+# We're getting this from Debian Sid
_debname=icedove
_debver=17.0.5
-_debrel=1
+_debrel=2
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
_pkgname=${_debname}
pkgname=${_debname}-libre
pkgver=${_debver}.${_debrel}
-pkgrel=4
+pkgrel=1
pkgdesc="A libre version of Debian Icedove, the standalone mail/news reader based on Mozilla Thunderbird."
arch=('i686' 'x86_64' 'mips64el')
license=('MPL' 'GPL' 'LGPL')
-url="http://packages.debian.org/experimental/${_pkgname}"
+url="http://packages.debian.org/sid/${_pkgname}"
depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'mozilla-searchplugins' 'nss' 'sqlite' 'startup-notification')
-makedepends=('unzip-libre' 'zip' 'pkg-config' 'python2' 'wireless_tools' 'yasm' 'mesa' 'autoconf2.13' 'quilt')
+makedepends=('unzip-libre' 'zip' 'pkg-config' 'python2' 'python2-virtualenv' 'wireless_tools' 'yasm' 'mesa' 'autoconf2.13' 'quilt')
optdepends=('libcanberra: for sound support')
replaces=('thunderbird')
conflicts=('thunderbird')
@@ -26,21 +26,21 @@ install=${_pkgname}.install
source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.bz2"
"${_debrepo}/`debfile ${_debname}`_${_debver}-${_debrel}.debian.tar.gz"
mozconfig
+ replace-urls.txt
vendor.js
makefile.patch
branding.patch
${_pkgname}.desktop
- libre.patch
Icedove-branding.patch)
options=(!emptydirs)
md5sums=('0c68298c17757257da79b6bb39e3fd10'
- 'eb2a5e1877d87a16e10388f533c081a6'
+ '2086f544ef90570d7629374aeac22aa6'
'5cf95ea94f69cdd36604890cfbf7b954'
+ 'a8fc4658d45b6bf9350023e5c3f34e56'
'4eecc4fc5aafaf0da651a09eadc90bee'
'c4ed43e85945e180a89cce03e45ec62c'
'126b1446212396c33220936c01d9592d'
'e785e0c267f4435ae1a9aa0b03bcacfb'
- '2e36075067ddec9304b00ffe077705c2'
'ea5f7a06967f561d47d7e5c35b23de6f')
prepare() {
@@ -72,14 +72,25 @@ prepare() {
patch -Np1 -i "${srcdir}/branding.patch" # fixing branding
patch -Np1 -i "${srcdir}/Icedove-branding.patch" # debian patch fixed version
- # Patch anything that's left
- patch -Np1 -i "$srcdir/libre.patch"
+ # Replace common URLs
+ sed '/^#/d' ../replace-urls.txt | while read -r moz_url gnu_url; do
+ if [[ -n $moz_url ]]; then
+ printf 'liberating: %s -> %s\n' "$moz_url" "$gnu_url"
+ grep -Erl "${moz_url}" \
+ --exclude='*.'{patch,orig,rej} \
+ --exclude-dir={.pc,test,tests,testing} \
+ | xargs -d '\n' --no-run-if-empty sed -ri "s<${moz_url}<${gnu_url}<g"
+ fi
+ done
cp "${srcdir}/mozconfig" .mozconfig
# configure script misdetects the preprocessor without an optimization level
# https://bugs.archlinux.org/task/34644
sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
+
+ # Fix virtualenv path
+ sed -i 's|/usr/share/pyshared/virtualenv.py|/usr/lib/python2.7/site-packages/virtualenv.py|' mozilla/configure
}
build() {
@@ -112,5 +123,5 @@ package() {
ln -sf /usr/lib/mozilla/searchplugins "${pkgdir}/usr/lib/${_pkgname}/searchplugins"
# We don't want the development stuff
- rm -r "${pkgdir}"/usr/{include,lib/$_pkgname-devel,share/idl}
+ rm -r "${pkgdir}"/usr/{include,lib/${_pkgname}-devel,share/idl}
}