summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
index 38d2d9ef6..78fc58fa1 100644
--- a/libre/icecat/PKGBUILD
+++ b/libre/icecat/PKGBUILD
@@ -130,6 +130,15 @@ prepare() {
echo 'ac_add_options --disable-jemalloc' >> .mozconfig
fi
+ # Fixing for libvpx >= 1.4.0
+ sed -i 's|IMG_FMT_I420|VPX_IMG_FMT_I420|;
+ s|PLANE_U|VPX_PLANE_U|;
+ s|PLANE_V|VPX_PLANE_V|;
+ s|PLANE_Y|VPX_PLANE_Y|;
+ s|VPX_VPX_PLANE_|VPX_PLANE_|;
+ ' content/media/encoder/VP8TrackEncoder.cpp \
+ media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
+
mkdir "$srcdir/path"
# WebRTC build tries to execute "python" and expects Python 2