summaryrefslogtreecommitdiff
path: root/libre/hexchat/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/hexchat/PKGBUILD')
-rw-r--r--libre/hexchat/PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/libre/hexchat/PKGBUILD b/libre/hexchat/PKGBUILD
new file mode 100644
index 000000000..f2ecdbfbc
--- /dev/null
+++ b/libre/hexchat/PKGBUILD
@@ -0,0 +1,50 @@
+# $Id: PKGBUILD 116500 2014-07-28 22:25:29Z alucryd $
+# Maintainer (Arch): Maxime Gauduin <alucryd@gmail.com>
+# Contributor (Arch): TingPing <tingping@tingping.se>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+pkgname=hexchat
+pkgver=2.10.1
+pkgrel=1.parabola1
+pkgdesc='A popular and easy to use graphical IRC (chat) client, without nonfree browser reference (Parabola rebranded)'
+arch=('i686' 'x86_64' 'mips64el')
+url='http://hexchat.github.io/'
+license=('GPL')
+depends=('dbus-glib' 'desktop-file-utils' 'gtk2' 'libcanberra' 'libnotify' 'libproxy' 'pciutils')
+makedepends=('intltool' 'iso-codes' 'perl' 'python')
+optdepends=('enchant: Spell check'
+ 'perl: Perl plugin'
+ 'python: Python plugin')
+install="${pkgname}.install"
+replaces=(${pkgname}-libre)
+conflicts=(${pkgname}-libre)
+source=("http://dl.hexchat.org/${pkgname}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('ffccee6a3470d2f9539e75bd0dd2e3f35c65737004cb02e6d2106c1d5dcde9a9')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+
+ sed 's/CFLAGS="$PERL_CFLAGS"/CFLAGS="$PERL_CFLAGS -fuse-ld=gold"/' -i configure
+
+# Rebrand to Parabola
+ sed -i 's#ArchLinux#Parabola GNU/Linux-libre#' plugins/sysinfo/parse.c
+
+# Remove nonfree browser references
+ sed -i '\|NAME Open Link| s|Firefox|Iceweasel|' src/common/hexchat.c
+ sed -i '\|NAME Open Link| s|firefox -private %s\\n\\n";|iceweasel -private %s\\n\\n"\\\n "NAME Open Link in Private Icecat Window\\n" "CMD !icecat -private %s\\n\\n";|' src/common/hexchat.c
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ ./configure --prefix='/usr' --enable-{perl,python='python3.4',textfe}
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: