summaryrefslogtreecommitdiff
path: root/libre/gst-plugins-good/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/gst-plugins-good/PKGBUILD')
-rw-r--r--libre/gst-plugins-good/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/libre/gst-plugins-good/PKGBUILD b/libre/gst-plugins-good/PKGBUILD
new file mode 100644
index 000000000..9101bfdba
--- /dev/null
+++ b/libre/gst-plugins-good/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gst-plugins-good
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="GStreamer Multimedia Framework Good Plugins, Parabola rebranded"
+arch=('i686' 'x86_64' 'mips64el')
+license=('LGPL')
+url="http://gstreamer.freedesktop.org/"
+depends=('libpulse' 'jack' 'libsoup' 'gst-plugins-base-libs' 'wavpack' 'aalib' 'taglib' 'libdv' 'libshout' 'libvpx' 'gdk-pixbuf2' 'libcaca' 'libavc1394' 'libiec61883' 'libxdamage' 'v4l-utils' 'cairo')
+makedepends=('gstreamer' 'speex' 'flac' 'libraw1394')
+options=(!libtool !emptydirs)
+source=(${url}/src/$pkgname/$pkgname-$pkgver.tar.xz)
+sha256sums=('67f7690a9826d9a6ab28b9af2536a6f3e833ee412bd59dd603c48fb3c6823e0d')
+
+build() {
+ cd $pkgname-$pkgver
+ sed -i -e '/AC_PATH_XTRA/d' configure.ac
+ aclocal -I m4 -I common/m4
+ autoconf
+ automake --add-missing
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static --enable-experimental \
+ --with-package-name="GStreamer Good Plugins (Parabola GNU/Linux-libre)" \
+ --with-package-origin="https://parabolagnulinux.org/"
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
+}