summaryrefslogtreecommitdiff
path: root/libre/grub/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/grub/PKGBUILD')
-rw-r--r--libre/grub/PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/libre/grub/PKGBUILD b/libre/grub/PKGBUILD
index a0f936481..1c4625f9d 100644
--- a/libre/grub/PKGBUILD
+++ b/libre/grub/PKGBUILD
@@ -61,11 +61,8 @@ optdepends=('freetype2: For grub-mkfont usage'
'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue'
'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
'mtools: For grub-mkrescue FAT FS support')
-if [[ "${CARCH}" == "x86_64" ]]; then
- optdepends+=('xen: For boot support into XEN server')
-elif [[ "${CARCH}" == "i686" ]]; then
- optdepends+=('xen: For boot support into XEN server'
- 'linux-libre-xen: For boot support into XEN server')
+if [[ "${CARCH}" == "i686" ]]; then
+ optdepends+=('linux-libre-xen: For boot support into XEN server')
fi
if [[ "${_GRUB_EMU_BUILD}" == "1" ]] && [[ "${CARCH}" != "armv7h" ]]; then