summaryrefslogtreecommitdiff
path: root/libre/grub/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/grub/PKGBUILD')
-rw-r--r--libre/grub/PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/libre/grub/PKGBUILD b/libre/grub/PKGBUILD
index e7a5806b5..18b88f5c1 100644
--- a/libre/grub/PKGBUILD
+++ b/libre/grub/PKGBUILD
@@ -417,7 +417,7 @@ source=("grub-${_pkgver}::git+git://git.sv.gnu.org/grub.git#tag=${_GRUB_GIT_TAG}
'grub-add-GRUB_COLOR_variables.patch'
'60_memtest86+'
'grub.default'
- 'grub-10_linux-20_linux_xen-detect-devicetree-am335x_bone+am335x_boneblack.patch'
+ 'grub-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch'
'grub-10_linux-20_linux_xen-rebrand-free-distros.patch')
md5sums=('SKIP'
@@ -428,7 +428,7 @@ md5sums=('SKIP'
'e506ae4a9f9f7d1b765febfa84e10d48'
'be55eabc102f2c60b38ed35c203686d6'
'8d1dd54ae4a1b550c097e056892ce953'
- ''
+ '36b2a7531b615d5b8658a709b8104148'
'e0133ad89ab3014210d4599f396a556e')
validpgpkeys=('95D2E9AB8740D8046387FD151A09227B1F435A33') #Paul Hardy
@@ -859,9 +859,11 @@ _build_grub-uboot_am335x-bone() {
msg 'Patch to detect am335x-bone device tree blob file (dtb)'
patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-devicetree-dir.patch"
- msg 'change memory to am335x-bone support'
- sed -i 's|0x08000000|0x82000000|
- ' file
+ msg 'change memory adapted for am335x-bone support'
+ sed -i '\|arm_uboot_ldflags| s|0x08000000|0x82000000|
+ \|GRUB_KERNEL_ARM_UBOOT_LINK_ADDR| s|0x08000000|0x82000000|
+ ' grub-core/Makefile.core.def \
+ include/grub/offsets.h
msg 'Unset all compiler FLAGS for U-Boot (am335x-bone) build'
unset CFLAGS