summaryrefslogtreecommitdiff
path: root/libre/gnu-ghostscript/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/gnu-ghostscript/PKGBUILD')
-rwxr-xr-xlibre/gnu-ghostscript/PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/libre/gnu-ghostscript/PKGBUILD b/libre/gnu-ghostscript/PKGBUILD
index 4fb123c2c..3270a3d4d 100755
--- a/libre/gnu-ghostscript/PKGBUILD
+++ b/libre/gnu-ghostscript/PKGBUILD
@@ -5,24 +5,29 @@ pkgname=gnu-ghostscript
_pkgver=9.05
pkgver=9.05.0
pkgrel=1
-pkgdesc="An interpreter for the PostScript language created by the FSF"
+pkgdesc="An interpreter for the PostScript language maintained by a team of GNU programmers"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg' 'libtiff>=4.0.0' 'lcms') # 'lcms2' won't get used) # move in libpaper from community?
+depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg' 'libtiff>=4.0.0' 'lcms2')
makedepends=('gtk2' 'gnutls')
optdepends=('texlive-core: needed for dvipdf'
'gtk2: needed for gsx')
conflicts=${_pkgname}
replaces=${_pkgname}
-provides=${_pkgname}
+provides="${_pkgname}=9.06"
url="https://www.gnu.org/software/${_pkgname}/"
-source=(ftp://ftp.gnu.org/gnu/${_pkgname}/${pkgname}-${pkgver}.tar.xz)
+source=(ftp://ftp.gnu.org/gnu/${_pkgname}/${pkgname}-${pkgver}.tar.xz
+ libtool.patch)
options=('!libtool' '!makeflags')
-md5sums=('e80423be9abb32fc99cc897ed379a7df')
+md5sums=('e80423be9abb32fc99cc897ed379a7df'
+ '5bd5d4966007b460deed866a30a0b3c8')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
+ # fix libtool version
+ patch -Np1 -i ${srcdir}/libtool.patch
+
# force it to use system-libs
rm -rf jpeg libpng zlib jasper expat tiff lcms freetype