summaryrefslogtreecommitdiff
path: root/libre/gnome-boxes-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/gnome-boxes-libre/PKGBUILD')
-rw-r--r--libre/gnome-boxes-libre/PKGBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/libre/gnome-boxes-libre/PKGBUILD b/libre/gnome-boxes-libre/PKGBUILD
deleted file mode 100644
index 1c2bff72c..000000000
--- a/libre/gnome-boxes-libre/PKGBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# $Id: PKGBUILD 113793 2014-06-30 13:59:38Z bgyorgy $
-# Maintainer (Arch): Balló György <ballogyor+arch at gmail dot com>
-# Contributor (Arch): Stefano Facchini <stefano.facchini@gmail.com>
-# Maintainer: André Silva <emulatorman@parabola.nu>
-# Contributor: Daniel Milewski <niitotantei@gmail.com>
-
-_pkgname=gnome-boxes
-pkgname=gnome-boxes-libre
-pkgver=3.12.3
-pkgrel=1
-pkgdesc="Simple GNOME 3 application to access remote or virtual systems, without nonfree system logos"
-arch=('i686' 'x86_64' 'mips64el')
-url="https://wiki.gnome.org/Apps/Boxes"
-license=('LGPL')
-provides=($_pkgname=$pkgver)
-conflicts=($_pkgname)
-replaces=($_pkgname)
-depends=('clutter-gtk' 'gtk-vnc' 'libosinfo' 'libsoup' 'libvirt-glib' 'spice-gtk3'
- 'libtracker-sparql' 'qemu' 'cdrkit' 'libcdio' 'mtools' 'dconf'
- 'gnome-icon-theme' 'gnome-themes-standard')
-makedepends=('gobject-introspection' 'intltool' 'itstool' 'spice-protocol' 'vala')
-install=$_pkgname.install
-source=(http://ftp.gnome.org/pub/GNOME/sources/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.xz
- libre.patch)
-sha256sums=('bf57525106baaa635d08a4a4c6ed81e4b8c8708897f2fe7c2623810aec9b6408'
- '2a93935ba94b9f327645a92f11d1a3d23cbeab8e5c800e414c6762181f51d4c0')
-
-prepare() {
- cd $_pkgname-$pkgver
-
- patch -Np1 -i "$srcdir/libre.patch"
-}
-
-build() {
- cd $_pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib/$_pkgname \
- --disable-static --disable-schemas-compile --enable-smartcard
- make
-}
-
-package() {
- cd $_pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-}