summaryrefslogtreecommitdiff
path: root/libre/ghostscript/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/ghostscript/PKGBUILD')
-rw-r--r--libre/ghostscript/PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/libre/ghostscript/PKGBUILD b/libre/ghostscript/PKGBUILD
index cd3c594b8..0246b2310 100644
--- a/libre/ghostscript/PKGBUILD
+++ b/libre/ghostscript/PKGBUILD
@@ -1,14 +1,14 @@
-# $Id: PKGBUILD 235306 2015-03-31 17:24:09Z andyrtr $
+# $Id: PKGBUILD 248863 2015-10-10 13:01:47Z andyrtr $
# Maintainer (Arch): AndyRTR <andyrtr@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
### !!! rebuild groff from core that picks up hardcoding the GS versioned font path !!! ###
pkgname=ghostscript
-pkgver=9.16
-pkgrel=1.parabola1
+pkgver=9.18
+pkgrel=2.parabola1
pkgdesc="An interpreter for the PostScript language, without nonfree JPEG XR support"
-arch=('i686' 'x86_64' 'mips64el')
+arch=('i686' 'x86_64')
license=('AGPL' 'custom')
depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg'
'libtiff>=4.0.0' 'lcms2' 'dbus' 'libpaper')
@@ -21,12 +21,14 @@ url="http://www.ghostscript.com/"
mksource=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2)
source=(https://repo.parabola.nu/other/ghostscript-libre/ghostscript-libre-${pkgver}.tar.bz2
ghostscript-sys-zlib.patch
+ bug_696246.diff
libre.patch)
#options=('!makeflags')
# http://downloads.ghostscript.com/public/SHA1SUMS
-mksha1sums=('529e2b0be754cb353880a4ac97e3efa47ef82f5c')
-sha1sums=('0a3d1c0f08ca5a8805c58a56ff1e760beca280c9'
+mksha1sums=('388fea50a38e422a4c6ff27c184491bf5ecb96e1')
+sha1sums=('6899da0407e4bf4a9f65848e68df237ed83c04ee'
'e054caf753df4d67221b29a2eac66130653f7556'
+ '8bdcb72250f81d8d1f3b3cff4becb673113ed302'
'51f821faec00749ed8b61d772879269f9809f694')
mksource() {
cd ghostscript-${pkgver}
@@ -39,6 +41,8 @@ prepare() {
cd ghostscript-${pkgver}
# fix build with system zlib
patch -Np1 -i ${srcdir}/ghostscript-sys-zlib.patch
+ # fix http://bugs.ghostscript.com/show_bug.cgi?id=696246 - should also be FS#46637
+ patch -Np1 -i ${srcdir}/bug_696246.diff
# remove nonfree JPEG XR reference on the license file
patch -Np1 -i ${srcdir}/libre.patch
}