summaryrefslogtreecommitdiff
path: root/libre/ghostscript/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/ghostscript/PKGBUILD')
-rw-r--r--libre/ghostscript/PKGBUILD93
1 files changed, 0 insertions, 93 deletions
diff --git a/libre/ghostscript/PKGBUILD b/libre/ghostscript/PKGBUILD
deleted file mode 100644
index e7f904578..000000000
--- a/libre/ghostscript/PKGBUILD
+++ /dev/null
@@ -1,93 +0,0 @@
-# $Id: PKGBUILD 274623 2016-08-24 16:07:01Z andyrtr $
-# Maintainer (Arch): AndyRTR <andyrtr@archlinux.org>
-# Maintainer: André Silva <emulatorman@parabola.nu>
-
-pkgname=ghostscript
-pkgver=9.19
-pkgrel=3.parabola1
-pkgdesc="An interpreter for the PostScript language, without nonfree JPEG XR support"
-arch=('i686' 'x86_64' 'armv7h')
-license=('AGPL' 'custom')
-depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg'
- 'libtiff>=4.0.0' 'lcms2' 'dbus' 'libpaper')
-makedepends=('gtk3' 'gnutls' 'hardening-wrapper' 'ijs')
-optdepends=('texlive-core: needed for dvipdf'
- 'gtk3: needed for gsx')
-conflicts=('ghostscript-libre')
-replaces=('ghostscript-libre')
-url="http://www.ghostscript.com/"
-mksource=(https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${pkgver/./}/ghostscript-${pkgver}.tar.bz2)
-source=(https://repo.parabola.nu/other/ghostscript-libre/ghostscript-libre-${pkgver}.tar.bz2
- ghostscript-sys-zlib.patch
- libre.patch)
-#options=('!makeflags')
-# https://github.com/ArtifexSoftware/ghostpdl-downloads/releases
-mksha1sums=('4aeb7c259dac524b3147447cf5dd5753d846ad11')
-sha1sums=('32378d7286ab78060bf98c877c735ef887d55ad0'
- 'e054caf753df4d67221b29a2eac66130653f7556'
- '51f821faec00749ed8b61d772879269f9809f694')
-mksource() {
- cd ghostscript-${pkgver}
- # JPEG XR is nonfree because it has the following license that forbids making modifications that
- # do not comply with the ITU standard and might have other issues.
- rm -rfv jpegxr
-}
-
-prepare() {
- cd ghostscript-${pkgver}
- # fix build with system zlib
- patch -Np1 -i ${srcdir}/ghostscript-sys-zlib.patch
- # remove nonfree JPEG XR reference on the license file
- patch -Np1 -i ${srcdir}/libre.patch
-}
-
-build() {
- cd ghostscript-${pkgver}
-
- # force it to use system-libs
- # keep heavily patched included openjpeg, leads to segfault with system openjpeg
- # https://bugs.archlinux.org/task/38226
- rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 freetype cups/libs # jbig2dec is in community
-
- autoconf --force
-
- ./configure --prefix=/usr \
- --enable-dynamic \
- --with-ijs \
- --with-jbig2dec \
- --with-omni \
- --with-x \
- --with-drivers=ALL\
- --with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
- --enable-fontconfig \
- --enable-freetype \
- --enable-openjpeg \
- --without-luratech \
- --without-omni \
- --with-system-libtiff \
- --with-libpaper \
- --disable-compile-inits #--help # needed for linking with system-zlib
- make so
- make
-}
-
-package() {
- cd ghostscript-${pkgver}
- make DESTDIR="${pkgdir}" \
- cups_serverroot="${pkgdir}"/etc/cups \
- cups_serverbin="${pkgdir}"/usr/lib/cups install install-so
-
- # drop full libs linked gs, prefer gsc dynamically linked against libgs; FS#50422
- ln -sf /usr/bin/gsc "${pkgdir}"/usr/bin/gs
-
- # install missing doc files # http://bugs.archlinux.org/task/18023
- install -m 644 "${srcdir}"/ghostscript-${pkgver}/doc/{VectorDevices.htm,gs-vms.hlp,gsdoc.el,pscet_status.txt} "${pkgdir}"/usr/share/ghostscript/$pkgver/doc/
-
- install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
-
- # remove unwanted localized man-pages
- rm -rf "$pkgdir"/usr/share/man/[^man1]*
-
- # remove filters that are now maintained in cups-filters as upstream home
- rm -rf "$pkgdir"/usr/lib/cups/filter/{gstopxl,gstoraster}
-}