summaryrefslogtreecommitdiff
path: root/libre/ghostscript-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/ghostscript-libre/PKGBUILD')
-rw-r--r--libre/ghostscript-libre/PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/libre/ghostscript-libre/PKGBUILD b/libre/ghostscript-libre/PKGBUILD
index 9aceaadd1..d339089af 100644
--- a/libre/ghostscript-libre/PKGBUILD
+++ b/libre/ghostscript-libre/PKGBUILD
@@ -1,18 +1,20 @@
-# $Id: PKGBUILD 183802 2013-04-28 00:51:13Z eric $
+# $Id: PKGBUILD 193812 2013-09-02 09:41:54Z andyrtr $
# Maintainer: AndyRTR <andyrtr@archlinux.org>
# Maintainer (Parabola): Joshua Haase <hahj87@gmail.com>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
+### !!! rebuild groff from core that picks up hardcoding the GS versioned font path !!! ###
+
_pkgname=ghostscript
pkgname=ghostscript-libre
-pkgver=9.07
-pkgrel=2
-pkgdesc="An interpreter for the PostScript language without nonfree files"
+pkgver=9.10
+pkgrel=1
+pkgdesc="An interpreter for the PostScript language, without nonfree files"
arch=('i686' 'x86_64' 'mips64el')
license=('AGPL') #non free files removed
depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg'
- 'libtiff>=4.0.0' 'lcms' 'dbus')
-makedepends=('gtk2' 'gnutls')
+ 'libtiff>=4.0.0' 'lcms2' 'dbus')
+makedepends=('gtk2' 'gnutls' 'openjpeg')
optdepends=('texlive-core: needed for dvipdf'
'gtk2: needed for gsx')
conflicts=('ghostscript')
@@ -20,18 +22,18 @@ replaces=('ghostscript')
provides=("ghostscript=$pkgver")
url="http://www.ghostscript.com/"
source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2)
-options=('!libtool')
-md5sums=('eea27befc1e85bef6d4768202f6b03a5')
+options=('!libtool' '!makeflags')
+md5sums=('7179bb1ed4f6f453147e6f7e1f210ce8')
build() {
cd ghostscript-${pkgver}
- # delete non-free packages
+ # delete nonfree files
grep -l "are not altered" Resource/CMap/* | xargs rm -fv
grep -l "not be copied" Resource/CMap/* | xargs rm -fv
# force it to use system-libs
- rm -rf jpeg libpng zlib jasper expat tiff lcms freetype
+ rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 freetype openjpeg cups/libs # jbig2dec is in community
./configure --prefix=/usr \
--enable-dynamic \
@@ -60,7 +62,7 @@ build() {
package() {
cd ghostscript-${pkgver}
- make -j1 DESTDIR="${pkgdir}" \
+ make DESTDIR="${pkgdir}" \
cups_serverroot="${pkgdir}"/etc/cups \
cups_serverbin="${pkgdir}"/usr/lib/cups install soinstall
@@ -74,5 +76,8 @@ package() {
# install IJS
cd ijs
- make -j1 DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install
+
+ # remove filters that are now maintained in cups-filters as upstream home
+ rm -rf "$pkgdir"/usr/lib/cups/filter/{gstopxl,gstoraster}
}