summaryrefslogtreecommitdiff
path: root/libre/epiphany/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/epiphany/PKGBUILD')
-rw-r--r--libre/epiphany/PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/libre/epiphany/PKGBUILD b/libre/epiphany/PKGBUILD
index 8c740de3e..5145d0823 100644
--- a/libre/epiphany/PKGBUILD
+++ b/libre/epiphany/PKGBUILD
@@ -8,18 +8,20 @@
# parabola changes and rationale:
# - rebranded to parabola
# - switched default searchengine to duckduckgo
+# - removed useless dependency on icu because it's not
+# used at runtime according to readelf -d
pkgname=epiphany
pkgver=3.36.1
pkgrel=2
-pkgrel+=.parabola1
+pkgrel+=.parabola2
pkgdesc="A GNOME web browser based on the WebKit rendering engine"
pkgdesc+=", with DuckDuckGo HTML support"
url="https://wiki.gnome.org/Apps/Web"
arch=(x86_64)
arch+=(i686 armv7h)
license=(GPL)
-depends=(webkit2gtk gcr icu libdazzle libhandy)
+depends=(webkit2gtk gcr libdazzle libhandy)
makedepends=(docbook-xml startup-notification lsb-release gobject-introspection yelp-tools
appstream-glib git meson)
checkdepends=(xorg-server-xvfb)
@@ -53,9 +55,5 @@ check() {
}
package() {
- local _icu_ver
- _icu_ver=$(pacman -S --print-format='%v' icu)
- depends+=("icu>=${_icu_ver}" "icu<$((${_icu_ver%%.*} + 1))")
-
DESTDIR="$pkgdir" meson install -C build
}