summaryrefslogtreecommitdiff
path: root/libre/clementine/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/clementine/PKGBUILD')
-rw-r--r--libre/clementine/PKGBUILD82
1 files changed, 14 insertions, 68 deletions
diff --git a/libre/clementine/PKGBUILD b/libre/clementine/PKGBUILD
index ee9b381f4..dffb5bc70 100644
--- a/libre/clementine/PKGBUILD
+++ b/libre/clementine/PKGBUILD
@@ -15,47 +15,17 @@
# - build from release tarball instead of VCS
pkgname=clementine
-_pkgname=$pkgname-libre
-pkgver=1.3.1.r831.664c5a31f
-pkgrel=3
-pkgrel+=.parabola2
+pkgver=1.4.0rc1
+pkgrel=1
+pkgrel+=.parabola1
pkgdesc='A modern music player and library organizer'
pkgdesc+=', without nonfree artwork and Spotify support'
url=https://www.clementine-player.org/
license=(GPL)
arch=(x86_64)
arch+=(i686 armv7h)
-depends=(
- chromaprint
- crypto++
- fftw
- glew
- glib2
- gst-plugins-base-libs
- gstreamer
- libcdio
- libgl
- libgpod
- liblastfm-qt5
- libmtp
- libmygpo-qt5
- libpulse
- libx11
- protobuf
- qt5-base
- qt5-x11extras
- sqlite
- zlib
- libprotobuf.so
-)
-makedepends=(
- boost
- cmake
- git
- mesa
- qt5-tools
- sparsehash
-)
+depends=(chromaprint crypto++ glew gst-plugins-base-libs libcdio libgpod liblastfm-qt5 libmtp libmygpo-qt5 protobuf qt5-x11extras)
+makedepends=(boost cmake qt5-tools sparsehash)
optdepends=(
'gst-plugins-base: "Base" plugin libraries'
'gst-plugins-good: "Good" plugin libraries'
@@ -64,39 +34,18 @@ optdepends=(
'gst-libav: Libav plugin'
'gvfs: Various devices support'
)
-source=(
- git+https://github.com/clementine-player/Clementine.git#commit=664c5a31f9cf519af5a4c3adcb30dbbc73d037d6
- clementine-gcc6.patch
- remove-nonfree-artwork-and-spotify.patch
- moognu.png
-)
-sha256sums=('SKIP'
- '05bd4dc0138eed084332fa1a688a96858418731f337f54e0d8ab0853123f40ee'
+source=("https://github.com/clementine-player/Clementine/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+ remove-nonfree-artwork-and-spotify.patch
+ moognu.png)
+
+sha256sums=('96ba2f5f3ece47b2c1065e980dcc37ada93ea42cf37b794ee804514ce4a65459'
'75536b5290ebcd6126d9e8796c3f15a0b0d5339257060ebab511dfe665d64e32'
'c6918617769152f3617c61f721819e69d03f671b85760b11cfe45abd53955bc4')
-pkgver() {
- cd Clementine
-
- git describe --tags | sed 's/-/.r/; s/-g/./'
-}
-
prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
+ mkdir -p build
- cd Clementine
-
- # Fix build with GCC 6
- patch -p1 -i ../clementine-gcc6.patch
- # https://github.com/clementine-player/Clementine/pull/5630
- git cherry-pick -n 8a6cc8b5069265e1e92e22def985e22c5955e503
- # FS#58413
- git cherry-pick -n -m 1 75f9439843a0e9cdc26cd739d5e1dbd93bd974bc
- # Fix DI.FM
- git cherry-pick -n ddfa5e63f1ef0e243a007efbe576fceb9b2442e8
+ cd "$pkgname-$pkgver"
# remove nonfree artwork for the Nyan Cat plugin
# https://labs.parabola.nu/issues/329
@@ -129,14 +78,11 @@ prepare() {
build() {
cd build
- cmake ../Clementine \
- -DCMAKE_BUILD_TYPE=Release \
+ cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- make DESTDIR="${pkgdir}" -C build install
+ make DESTDIR="$pkgdir" -C build install
}
-
-# vim: ts=2 sw=2 et: