summaryrefslogtreecommitdiff
path: root/libre/clementine-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/clementine-libre/PKGBUILD')
-rw-r--r--libre/clementine-libre/PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/libre/clementine-libre/PKGBUILD b/libre/clementine-libre/PKGBUILD
index 89201cf74..2fc816bef 100644
--- a/libre/clementine-libre/PKGBUILD
+++ b/libre/clementine-libre/PKGBUILD
@@ -2,13 +2,13 @@
#Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
#Contributor: BlackEagle <ike.devolder@gmail.com>
#Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
-#Maintainer (Parabola): André Silva <andre.paulista@adinet.com.uy>
-#Contributor (Parabola): Kete <kete@ninthfloor.org>
+#Maintainer (Parabola): Kete <kete@ninthfloor.org>
+#Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
_pkgname=clementine
pkgname=clementine-libre
pkgver=1.0.1
-pkgrel=3
+pkgrel=3.1
pkgdesc="A music player and library organizer, without spotify support"
url="http://www.clementine-player.org/"
license=('GPL')
@@ -27,11 +27,11 @@ provides=("clementine=$pkgver")
source=(http://clementine-player.googlecode.com/files/${_pkgname}-${pkgver}.tar.gz
clementine-fix-albumcoverfetch-crash.patch
clementine-fresh-start.patch
- disable-spotify.patch)
+ remove-and-disable-spotify.patch)
sha1sums=('e05320da689e2fad744fd3e68518bc4103ecf0fd'
'fddd2e784181ce1dcc7809e7122cbade0af7b01f'
'd8abab4b8fb2d5284a2f43107505325e62d4af5f'
- 'ae796afc31bbd97c03513496cee335cb2601dca4')
+ '2c723f14f438d356398bc729d0bc2ac43feed911')
install=clementine.install
build() {
@@ -44,7 +44,10 @@ build() {
patch -Np1 -i ../clementine-fix-albumcoverfetch-crash.patch
# https://labs.parabola.nu/issues/99
- patch -Np1 -i ../disable-spotify.patch
+ patch -Np1 -i ../remove-and-disable-spotify.patch
+
+ # Remove nonfree spotifyblob folder
+ rm -Rf "./spotifyblob"
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DENABLE_REMOTE=ON
make