summaryrefslogtreecommitdiff
path: root/libre/cbootimage/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/cbootimage/PKGBUILD')
-rw-r--r--libre/cbootimage/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/libre/cbootimage/PKGBUILD b/libre/cbootimage/PKGBUILD
new file mode 100644
index 000000000..0da635fe7
--- /dev/null
+++ b/libre/cbootimage/PKGBUILD
@@ -0,0 +1,33 @@
+# Tegra BCT and bootable flash image generator/compiler
+# Maintainer (Arch): Kevin Mihelich <kevin@archlinuxarm.org>
+
+buildarch=4
+
+pkgname=cbootimage
+pkgver=r68.b7d5b2d
+pkgrel=1
+pkgdesc="Tegra BCT and bootable flash image generator/compiler"
+arch=('armv7h')
+url="https://github.com/NVIDIA/cbootimage.git"
+makedepends=('git')
+license=('GPL')
+source=("git+https://github.com/NVIDIA/cbootimage.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd cbootimage
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd cbootimage
+
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd cbootimage
+
+ make DESTDIR="${pkgdir}" install
+}