summaryrefslogtreecommitdiff
path: root/libre/calibre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/calibre/PKGBUILD')
-rw-r--r--libre/calibre/PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/libre/calibre/PKGBUILD b/libre/calibre/PKGBUILD
index 2c84e4ba4..dc5cdfdce 100644
--- a/libre/calibre/PKGBUILD
+++ b/libre/calibre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 208674 2017-01-23 22:28:22Z arojas $
+# $Id: PKGBUILD 209389 2017-01-29 15:52:16Z jelle $
# Maintainer (Arch): Jelle van der Waa <jelle@vdwaa.nl>
# Maintainer (Arch): Daniel Wallace <danielwallace at gtmanfred dot com>
# Contributor (Arch): Giovanni Scafora <giovanni@archlinux.org>
@@ -10,8 +10,8 @@
# Contributor: Márcio Silva <coadde@parabola.nu>
pkgname=calibre
-pkgver=2.77.0
-pkgrel=3.parabola1
+pkgver=2.78.0
+pkgrel=2.parabola1
pkgdesc="Ebook management application, without nonfree decompression engine for RAR archives"
arch=('i686' 'x86_64' 'armv7h')
url="https://calibre-ebook.com/"
@@ -23,7 +23,7 @@ depends=('python2-six' 'python2-dateutil' 'python2-cssutils' 'python2-cherrypy'
'python2-pyqt5' 'python2-psutil' 'icu' 'libmtp' 'python2-dbus'
'python2-netifaces' 'python2-cssselect' 'python2-apsw' 'qt5-webkit'
'qt5-svg' 'python2-chardet' 'python2-pygments' 'mtdev'
- 'desktop-file-utils' 'gtk-update-icon-cache' 'optipng')
+ 'desktop-file-utils' 'gtk-update-icon-cache' 'optipng' 'udisks2')
makedepends=('qt5-x11extras' 'xdg-utils')
optdepends=('ipython2: to use calibre-debug'
'poppler: required for converting pdf to html'
@@ -33,13 +33,11 @@ conflicts=($pkgname-libre)
mksource=("http://download.$pkgname-ebook.com/${pkgver}/$pkgname-${pkgver}.tar.xz"
"https://calibre-ebook.com/signatures/${pkgname}-${pkgver}.tar.xz.sig")
source=("https://repo.parabola.nu/other/${pkgname}-libre/${pkgname}-libre-${pkgver}.tar.xz"
- 'libre.patch'
- 'calibre-qt-5.8.patch')
-mksha256sums=('575d1f197d5df95258ac6de3b2b7f6f8706e38d0044dbb4ae791653d229b69c0'
+ 'libre.patch')
+mksha256sums=('d2b0b0c5451d3ac05ce9de0b801ddf8de7664fee45f273d7ee8445a1ec2f898b'
'SKIP')
-sha256sums=('5e59e43603477983c1a272bf71f20306b2640063ab30459a4de435c99abdae91'
- '566a190f7675584acab4ceb84d504d939760a5d8644b79b4c76e68fb24515caa'
- 'a6538289b95156367a1bdb4523b58b73a56744792812ebcbdaeac26812d8f564')
+sha256sums=('988bd7e0d37d92ba6f60ac1ab8d2cee146d79d45fb679f966b9d7c21f026ca18'
+ '566a190f7675584acab4ceb84d504d939760a5d8644b79b4c76e68fb24515caa')
validpgpkeys=('3CE1780F78DD88DF45194FD706BC317B515ACE7C')
mksource(){
@@ -72,9 +70,6 @@ prepare(){
-e "s/'ctc-posml'/'text' not in mt and 'pdf' not in mt and 'xhtml'/" \
-e "s/^Name=calibre/Name=Calibre/g" \
-i src/calibre/linux.py
-
- # Fix build with Qt 5.8
- patch -p1 -i ../calibre-qt-5.8.patch
}
build() {