summaryrefslogtreecommitdiff
path: root/libre/calibre-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/calibre-libre/PKGBUILD')
-rw-r--r--libre/calibre-libre/PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/libre/calibre-libre/PKGBUILD b/libre/calibre-libre/PKGBUILD
index 51f0a0c0a..7991897ce 100644
--- a/libre/calibre-libre/PKGBUILD
+++ b/libre/calibre-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 91009 2013-05-17 10:26:19Z jelle $
+# $Id: PKGBUILD 93610 2013-07-07 09:52:43Z jelle $
# Maintainer: jelle van der Waa <jelle@vdwaa.nl>
# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
@@ -9,7 +9,7 @@
_pkgname=calibre
pkgname=calibre-libre
-pkgver=0.9.31
+pkgver=0.9.38
pkgrel=1
pkgdesc="Ebook management application, with unar support included and nonfree fonts removed"
arch=('i686' 'x86_64' 'mips64el')
@@ -19,7 +19,7 @@ depends=('python2-six' 'python2-dateutil' 'python2-cssutils' 'python2-cherrypy'
'python2-mechanize' 'podofo' 'libwmf' 'python2-beautifulsoup3'
'imagemagick' 'poppler-qt' 'chmlib' 'python2-lxml' 'libusbx'
'python2-imaging' 'shared-mime-info' 'python2-dnspython'
- 'unar' 'python2-pyqt' 'python2-psutil' 'icu' 'libmtp'
+ 'unar' 'python2-pyqt4' 'python2-psutil' 'icu' 'libmtp'
'python2-netifaces' 'python2-cssselect')
makedepends=('python2-pycountry' 'qt4-private-headers')
optdepends=('ipython2: to use calibre-debug')
@@ -27,16 +27,14 @@ replaces=$_pkgname
conflicts=$_pkgname
provides=$_pkgname=$pkgver
install=calibre.install
-source=("http://calibre-ebook.googlecode.com/files/${_pkgname}-${pkgver}.tar.xz"
+source=("http://sourceforge.net/projects/calibre/files/${pkgver}/calibre-${pkgver}.tar.xz"
'desktop_integration.patch'
'calibre-mount-helper')
-md5sums=('19abde7fd5a065cadfaee4ed12568d96'
+md5sums=('7dac0c5896d3affb87667fe5dbdf9019'
'8353d1878c5a498b3e49eddef473605f'
'675cd87d41342119827ef706055491e7')
-
-build() {
+prepare(){
cd "${srcdir}/${_pkgname}"
-
#rm -rf src/{cherrypy,pyPdf}
rm -rf src/cherrypy
rm -rf resources/${pkgname}-portable.*
@@ -47,7 +45,10 @@ build() {
sed -i -e 's:\(#!/usr/bin/env[ ]\+python$\|#![ ]/usr/bin/env[ ]\+python$\|#!/usr/bin/python$\):\12:g' \
$(find . -regex ".*.py\|.*.recipe")
+}
+build() {
+ cd "${srcdir}/${_pkgname}"
# Remove nonfree fonts
cd resources/fonts; \
rm prs500/tt0003m_.ttf; ln -s ../liberation/LiberationSans-Regular.ttf prs500/tt0003m_.ttf; \
@@ -57,7 +58,9 @@ build() {
LANG='en_US.UTF-8' python2 setup.py build
# LANG='en_US.UTF-8' python2 setup.py resources
- LANG='en_US.UTF-8' python2 setup.py translations
+
+ # Don't build translations since building them is broken badly
+#LANG='en_US.UTF-8' python2 setup.py translations
}
package() {