summaryrefslogtreecommitdiff
path: root/libre/calibre-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/calibre-libre/PKGBUILD')
-rw-r--r--libre/calibre-libre/PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/libre/calibre-libre/PKGBUILD b/libre/calibre-libre/PKGBUILD
index 6118642c4..2205ffc11 100644
--- a/libre/calibre-libre/PKGBUILD
+++ b/libre/calibre-libre/PKGBUILD
@@ -1,5 +1,5 @@
-# $Id: PKGBUILD 110173 2014-04-25 19:47:10Z jelle $
-# Maintainer: jelle van der Waa <jelle@vdwaa.nl>
+# $Id: PKGBUILD 110547 2014-05-03 08:51:00Z jelle $
+# Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Petrov Roman <nwhisper@gmail.com>
@@ -9,7 +9,7 @@
_pkgname=calibre
pkgname=calibre-libre
-pkgver=1.34.0
+pkgver=1.35.0
pkgrel=1
pkgdesc="Ebook management application, without nonfree libunrar support"
arch=('i686' 'x86_64' 'mips64el')
@@ -27,28 +27,33 @@ replaces=$_pkgname
conflicts=$_pkgname
provides=$_pkgname=$pkgver
install=calibre.install
-mksource=("http://download.calibre-ebook.com/${pkgver}/calibre-${pkgver}.tar.xz"
- 'libre.patch')
+mksource=("http://download.calibre-ebook.com/${pkgver}/calibre-${pkgver}.tar.xz")
source=("https://repo.parabolagnulinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz"
'desktop_integration.patch'
- 'calibre-mount-helper')
-mkmd5sums=('1621d563c0cd46d582f8fdf8c44dbb6f'
- '1540d92a314bf748b60b8fc436777ccb')
-md5sums=('38469886ead2808b81555ab2f505da7c'
+ 'calibre-mount-helper'
+ 'libre.patch')
+mkmd5sums=('fa98868fc6b446a8c22ef13475e6d224')
+md5sums=('78e6d511b77c6cc485f92d81961f31b7'
'ece36dfd737fa4a346f0a0e59395e949'
- '675cd87d41342119827ef706055491e7')
+ '675cd87d41342119827ef706055491e7'
+ '64b6798f526165146084e447cc3d9e1a')
mksource(){
cd "${srcdir}/${_pkgname}"
- # Remove unrar files from the source
+ # Remove nonfree unRAR utility files from the source
rm -rv src/unrar
- rm -v src/calibre/utils/unrar.{cpp,py}
- patch -Np1 -i "${srcdir}/libre.patch"
}
prepare(){
cd "${srcdir}/${_pkgname}"
+
+ # Remove rar/cbr references
+ rm -v src/calibre/{ebooks/metadata/rar.py,utils/unrar.{cpp,py}}
+ rm -v resources/images/mimetypes/{cbr,rar}.png
+ rm -v imgsrc/mimetypes/rar.svg
+ patch -Np1 -i "${srcdir}/libre.patch"
+
#rm -rf src/{cherrypy,pyPdf}
rm -rf src/cherrypy
rm -rf resources/${pkgname}-portable.*