summaryrefslogtreecommitdiff
path: root/libre/bbswitch-parabola-grsec/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/bbswitch-parabola-grsec/PKGBUILD')
-rw-r--r--libre/bbswitch-parabola-grsec/PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/libre/bbswitch-parabola-grsec/PKGBUILD b/libre/bbswitch-parabola-grsec/PKGBUILD
new file mode 100644
index 000000000..e00800dfa
--- /dev/null
+++ b/libre/bbswitch-parabola-grsec/PKGBUILD
@@ -0,0 +1,59 @@
+# $Id: PKGBUILD 116821 2014-08-04 07:12:07Z tpowa $
+# Maintainer (Arch): Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor (Arch): M0Rf30
+# Contributor (Arch): Samsagax <samsagax@gmail.com>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+# Contributor: Luke Shumaker <lukeshu@sbcglobal.net>
+# Contributor: Márcio Silva <coadde@parabola.nu>
+
+# Kernel info
+_basekernel=3.15
+_kernelname=-grsec
+
+# Source info
+_pkgname=bbswitch
+pkgver=0.8
+pkgdesc="Kernel module allowing to switch dedicated graphics card on Optimus laptops (built for the linux-libre${_kernelname} kernel package)"
+url="http://github.com/Bumblebee-Project/bbswitch"
+license=('GPL')
+source=("https://github.com/Bumblebee-Project/bbswitch/archive/v${pkgver}.tar.gz")
+md5sums=('5b116b31ace3604ddf9d1fc1f4bc5807')
+
+# Package info
+pkgrel=16.${_basekernel/./}
+arch=('i686' 'x86_64' 'mips64el')
+install='kmod.install'
+
+# Generic (you shouldn't have to modify any of these variables)
+pkgname=${_pkgname}-parabola${_kernelname}
+_toohigh=$(IFS=. read a b <<<$_basekernel; echo $a.$((b+1)))
+_extramodules=extramodules-${_basekernel}${_kernelname}
+depends=("linux-libre${_kernelname}>=${_basekernel}" "linux-libre${_kernelname}<${_toohigh}")
+makedepends=("linux-libre${_kernelname}-headers>=${_basekernel}" "linux-libre${_kernelname}-headers<${_toohigh}")
+replaces=( "${_pkgname}${_kernelname}") # for Arch-compatability
+conflicts=("${_pkgname}${_kernelname}") # for Arch-compatability
+provides=( "${_pkgname}${_kernelname}=${pkgver}") # for Arch-compatability
+if [[ -n "${_kernelname}" ]]; then
+ provides+=("${_pkgname}-parabola=${pkgver}") # pkgname without _kernelname
+fi
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+
+ make KDIR=/lib/modules/${_kernver}/build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Set the correct extramodules directory for install
+ cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
+ true && install=${install}.pkg
+ sed -r "s/(_extramodules=).*/\1${_extramodules}/" -i "${startdir}/${install}"
+
+ # Actually install
+ install -Dm644 bbswitch.ko "${pkgdir}"/usr/lib/modules/${_extramodules}/bbswitch.ko
+ gzip "${pkgdir}/usr/lib/modules/${_extramodules}/bbswitch.ko"
+}