summaryrefslogtreecommitdiff
path: root/libre/acpi_call-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/acpi_call-libre/PKGBUILD')
-rw-r--r--libre/acpi_call-libre/PKGBUILD45
1 files changed, 0 insertions, 45 deletions
diff --git a/libre/acpi_call-libre/PKGBUILD b/libre/acpi_call-libre/PKGBUILD
deleted file mode 100644
index 8fa5a4279..000000000
--- a/libre/acpi_call-libre/PKGBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# $Id: PKGBUILD 116819 2014-08-04 07:10:28Z tpowa $
-# Maintainer (Arch): Maxime Gauduin <alucryd@gmail.com>
-# Contributor (Arch): mortzu <me@mortzu.de>
-# Contributor (Arch): fnord0 <fnord0@riseup.net>
-# Maintainer: André Silva <emulatorman@parabola.nu>
-
-_pkgname=acpi_call
-pkgname=acpi_call-libre
-pkgver=1.1.0
-pkgrel=11
-_extramodules=extramodules-3.16-libre
-pkgdesc='A linux kernel module that enables calls to ACPI methods through /proc/acpi/call (built for the linux-libre kernel package)'
-arch=('i686' 'x86_64')
-url="http://github.com/mkottman/${_pkgname}"
-license=('GPL')
-depends=('linux-libre>=3.16' 'linux-libre<3.17')
-makedepends=('linux-libre-headers>=3.16' 'linux-libre-headers<3.17')
-replaces=("${_pkgname}")
-conflicts=("${_pkgname}")
-provides=("${_pkgname}=${pkgver}")
-install="${_pkgname}.install"
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('d0d14b42944282724fca76f57d598eed794ef97448f387d1c489d85ad813f2f0')
-
-build() {
- cd ${_pkgname}-${pkgver}
-
- _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-
- make KVERSION="${_kernver}"
-}
-
-package() {
- cd ${_pkgname}-${pkgver}
-
- install -dm 755 "${pkgdir}"/usr/lib/{modules/${_extramodules},modules-load.d}
- install -m 644 ${_pkgname}.ko "${pkgdir}"/usr/lib/modules/${_extramodules}
- gzip "${pkgdir}"/usr/lib/modules/${_extramodules}/${_pkgname}.ko
- echo ${_pkgname} > "${pkgdir}"/usr/lib/modules-load.d/${_pkgname}.conf
-
- install -dm 755 "${pkgdir}"/usr/share/${_pkgname}
- cp -dr --no-preserve='ownership' {examples,support} "${pkgdir}"/usr/share/${_pkgname}/
-}
-
-# vim: ts=2 sw=2 et: