summaryrefslogtreecommitdiff
path: root/libre/aarch64-linux-gnu-binutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/aarch64-linux-gnu-binutils/PKGBUILD')
-rw-r--r--libre/aarch64-linux-gnu-binutils/PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/libre/aarch64-linux-gnu-binutils/PKGBUILD b/libre/aarch64-linux-gnu-binutils/PKGBUILD
index d9321ccf9..de2c4ac78 100644
--- a/libre/aarch64-linux-gnu-binutils/PKGBUILD
+++ b/libre/aarch64-linux-gnu-binutils/PKGBUILD
@@ -1,16 +1,17 @@
+# Maintainer (arch): Anatol Pomozov <anatol.pomozov@gmail.com>
# Maintainer: David P. <megver83@parabola.nu>
_target=aarch64-linux-gnu
pkgname=$_target-binutils
-pkgver=2.34
+pkgver=2.38
pkgrel=1
pkgdesc='A set of programs to assemble and manipulate binary and object files for the aarch64 target'
-arch=('x86_64' 'i686' 'armv7h')
+arch=(armv7h i686 x86_64)
url='https://www.gnu.org/software/binutils/'
license=(GPL)
-depends=(zlib)
+depends=(zlib libelf)
source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig})
-sha512sums=('f47e7304e102c7bbc97958a08093e27796b9051d1567ce4fbb723d39ef3e29efa325ee14a1bdcc462a925a7f9bbbc9aee28294c6dc23850f371030f3835a8067'
+sha512sums=('7690b4158bd6587a85c6b98903980b9ac6f16b47f7fd1e60986b0a70388bedcfdc05d75597aa49c81fec1609ce24bed6c26583f76fd2471a9d63394fd9798afc'
'SKIP')
validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
'3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
@@ -23,7 +24,8 @@ prepare() {
build() {
cd binutils-$pkgver
- if [ "${CARCH}" != "i686" ]; then
+ if [ "${CARCH}" != "i686" ];
+ then
# enabling gold linker at i686 makes the install fail
enable_gold='--enable-gold'
fi
@@ -45,10 +47,10 @@ build() {
check() {
cd binutils-$pkgver
-
+
# unset LDFLAGS as testsuite makes assumptions about which ones are active
# do not abort on errors - manually check log files
- make LDFLAGS="" -k check || true
+ make -k LDFLAGS="" check || true
}
package() {
@@ -58,6 +60,7 @@ package() {
# Remove file conflicting with host binutils and manpages for MS Windows tools
rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
+ rm "$pkgdir"/usr/lib/bfd-plugins/libdep.so
# Remove info documents that conflict with host version
rm -r "$pkgdir"/usr/share/info