summaryrefslogtreecommitdiff
path: root/libre-testing/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/iceweasel/PKGBUILD')
-rw-r--r--libre-testing/iceweasel/PKGBUILD39
1 files changed, 13 insertions, 26 deletions
diff --git a/libre-testing/iceweasel/PKGBUILD b/libre-testing/iceweasel/PKGBUILD
index e5e1113d9..74cef31cf 100644
--- a/libre-testing/iceweasel/PKGBUILD
+++ b/libre-testing/iceweasel/PKGBUILD
@@ -8,6 +8,7 @@
# Contributor: Figue <ffigue at gmail>
# Contributor: taro-k <taro-k@movasense_com>
# Contributor: Michał Masłowski <mtjm@mtjm.eu>
+# Contributor: Luke R. <g4jc@openmailbox.org>
# Thank you very much to the older contributors:
# Contributor: evr <evanroman at gmail>
# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
@@ -16,9 +17,9 @@ _pgo=false
# We're getting this from Debian Sid
_debname=firefox
-_brandingver=48.0
+_brandingver=49.0
_brandingrel=1
-_debver=48.0
+_debver=49.0
_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
_parabolarepo=https://repo.parabola.nu/other/iceweasel
@@ -28,17 +29,13 @@ _pkgname=firefox
pkgname=iceweasel
epoch=1
pkgver=$_debver.$_debrel
-pkgrel=3
+pkgrel=2
pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 armv7h)
license=(MPL GPL LGPL)
-depends=(alsa-lib dbus-glib ffmpeg gtk2 gtk3 hunspell icu=57.1 libevent
- libvpx=1.6.0 libxt mime-types mozilla-common nss sqlite
- startup-notification ttf-font)
-makedepends=(autoconf2.13 diffutils gconf imagemagick imake inetutils libidl2
- libpulse librsvg-stable libxslt mesa mozilla-searchplugins
- pkg-config python2 quilt unzip yasm zip)
+depends=(alsa-lib dbus-glib ffmpeg gtk2 gtk3 hunspell icu=57.1 libevent libvpx=1.6.0 libxt mime-types mozilla-common nss sqlite startup-notification ttf-font)
+makedepends=(autoconf2.13 diffutils gconf imagemagick imake inetutils libidl2 libpulse librsvg-stable libxslt mesa mozilla-searchplugins pkg-config python2 quilt unzip yasm zip)
makedepends_i686=(rust)
makedepends_x86_64=("${makedepends_i686[@]}")
options=(!emptydirs !makeflags debug)
@@ -47,6 +44,7 @@ if $_pgo; then
options+=(!ccache)
fi
optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'libnotify: Notification integration'
'upower: Battery API')
url="https://wiki.parabola.nu/$pkgname"
replaces=("$pkgname-libre" "$_pkgname")
@@ -63,25 +61,21 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.xz"
$pkgname.desktop
$pkgname-install-dir.patch
vendor.js
- no-libnotify.patch
- $pkgname-gtk3-20.patch
enable-object-directory-paths.patch
mozilla-1253216.patch
mozilla-build-arm.patch)
-sha256sums=('032cc7c6da26b4336a6e0cea41a2821a149469b5cdeaec66723bf256bbf13ec5'
- 'bda6131cb58bedfb33ed372ab0b8ad666f8b6b310f4788c7415efb9e3ae30ec6'
- '0c4ce096711629db4a5f15415b9d752fd77c4eab7bfd22bd3cb6640ed9cbf861'
+sha256sums=('2f463afd3c74eb9477f58525214f06498357ff90f01b45fb2675fc77c57bcffe'
+ 'ad6e1da709e0f7e86da83fee84067968acd1678576c4cf1757214b2954780ce5'
+ 'c0fd88e37187298a7658919cf2e4b6d024425b781d6aff5bdba49dc991f379d3'
'SKIP'
- '6891d6237312914b579c632b71f9e4f613e7b00bbf2fd7ce53b4cf681820f609'
+ '69d612da53ed7eb04be20d0bfc51eb6e132216a7f7159dde37f4666973ca14d4'
'013af398e97da9e855a143582816bf819e0d9d8d2b0e323d6b832f3df1157fdd'
'32f1fe3ad4f80d0ae419064db2abe49b97cd7cb18c35d68be1a2befb60172a2a'
'93e3001ce152e1d142619e215a9ef07dd429943b99d21726c25da9ceb31e31cd'
'56eba484179c7f498076f8dc603d8795e99dce8c6ea1da9736318c59d666bff6'
- '2257dc69886bd0b72c48675a27c3a88b9cf6b598252c9e9f1c99763180684fc3'
+ '87034dbb640f70454b27d1695a6f03b6fd1ab81c82eb4d8c771db925ae03d408'
'3aea6676f1e53a09673b6ae219d281fc28054beb6002b09973611c02f827651d'
'e1c82f5f683258e17f7b3dba62a938e4efe4d232f45a4b82e74cd2793fd5f7fe'
- 'e4ebdd14096d177d264a7993dbd5df46463605ff45f783732c26d30b9caa53a7'
- 'c984c8bda3c173349d98f3fa71ec8ff8e8b74e6ca20a3f39f33596dbb4c4d1e8'
'e260e555b261aabab1e48786dd514eeea056e4402af7cfd4dfd1d32858441484'
'fbb6011501a74a8ea6d01c041870fcefb7ef2859c134aedc676e5f6452833f65'
'56eecee8162c138c442773d66483886f1242c8dd2b16eed5711ae5e63d9b0e3a')
@@ -116,13 +110,6 @@ prepare() {
# Install to /usr/lib/$pkgname
patch -Np1 -i "$srcdir/$pkgname-install-dir.patch"
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1234158
- patch -Np1 -i "$srcdir/$pkgname-gtk3-20.patch"
-
- # Notifications with libnotify are broken
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1236150
- patch -Np1 -i "$srcdir/no-libnotify.patch"
-
# Patch and remove anything that's left
patch -Np1 -i "$srcdir/libre.patch"
sed -i 's|Adobe Flash|SWF Player|g;
@@ -172,7 +159,7 @@ build() {
LDFLAGS+=" -Wl,-z,now"
# GCC 6
- CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
+ CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-schedule-insns2"
export PATH="$srcdir/path:$PATH"