summaryrefslogtreecommitdiff
path: root/libre-testing/icedove-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/icedove-libre/PKGBUILD')
-rw-r--r--libre-testing/icedove-libre/PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/libre-testing/icedove-libre/PKGBUILD b/libre-testing/icedove-libre/PKGBUILD
index d904e4d2e..de86019a3 100644
--- a/libre-testing/icedove-libre/PKGBUILD
+++ b/libre-testing/icedove-libre/PKGBUILD
@@ -25,13 +25,15 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
"$_debrepo/`debfile $_debname`_$_debver-$_debrel.dsc"
mozconfig
channel-prefs.js
- vendor.js)
+ vendor.js
+ gcc47.patch)
md5sums=('3efe2ef4d5471aae3b79531ce8aee9dc'
'cb3dba2916bdf2deb72248b0984c4302'
'57e21e997a75d85fcc0dcfe30b83f1ee'
- 'fda2ff093ddbddf7f4cc3a1ed3bf9dcd'
+ '76e01cfd6de4d4289265882774d1ba7d'
'476ec205162340fb0679f522c9d31c3b'
- '4eecc4fc5aafaf0da651a09eadc90bee')
+ '4eecc4fc5aafaf0da651a09eadc90bee'
+ '66376a8e934013078f0e646e49614937')
build() {
export QUILT_PATCHES=debian/patches
@@ -47,6 +49,7 @@ build() {
quilt push -a
cp "$srcdir/mozconfig" .mozconfig
+ patch -Np1 -i "$srcdir/gcc47.patch"
rm "$srcdir"/mozilla-build/mail/locales/en-US/searchplugins/{amazondotcom,aol-web-search,bing,twitter,yahoo}.xml
make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS"