summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-rt/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-rt/PKGBUILD')
-rwxr-xr-xkernels/linux-libre-rt/PKGBUILD52
1 files changed, 22 insertions, 30 deletions
diff --git a/kernels/linux-libre-rt/PKGBUILD b/kernels/linux-libre-rt/PKGBUILD
index 455905e98..30361d313 100755
--- a/kernels/linux-libre-rt/PKGBUILD
+++ b/kernels/linux-libre-rt/PKGBUILD
@@ -10,13 +10,13 @@
pkgbase=linux-libre-rt # Build stock -LIBRE-RT kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.4
-_releasever=11
-_rtpatchver=rt19
+_basekernel=3.6
+_releasever=6
+_rtpatchver=rt17
_pkgver=${_basekernel}.${_releasever}
pkgver=${_basekernel}.${_releasever}_${_rtpatchver}
pkgrel=1
-_lxopkgver=${_basekernel}.11 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.6 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -24,7 +24,7 @@ makedepends=('xmlto' 'docbook-xsl')
options=('!strip')
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
"http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgver}-gnu/patch-${_basekernel}-gnu-${_pkgver}-gnu.xz"
- "http://www.kernel.org/pub/linux/kernel/projects/rt/3.4/patch-${_pkgver}-${_rtpatchver}.patch.xz"
+ "http://www.kernel.org/pub/linux/kernel/projects/rt/${_basekernel}/patch-${_pkgver}-${_rtpatchver}.patch.xz"
# the main kernel config files
'config.i686' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -33,22 +33,22 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'Kbuild.platforms'
'boot-logo.patch'
'change-default-console-loglevel.patch'
- 'i915-fix-ghost-tv-output.patch'
- '3.4.4-fix-backlight-regression.patch'
+ 'module-symbol-waiting-3.6.patch'
+ 'module-init-wait-3.6.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
-md5sums=('a5e128ca059cceb8b69148b41ff4ac6f'
- '00eaf4013fc8cfe73498d910b0b5c826'
- 'be2541bbe5455203b054c6acc3f999bf'
- 'd176ceb303ecfb2303d9659ea2dd91c7'
- 'bcb219ab37ed19912126189cfca30538'
+md5sums=('a2312edd0265b5b07bd4b50afae2b380'
+ '887e4a0fd0fb10da9410f5d1a75466b8'
+ '20cd3b6ed53047a633d1e2b1ba32973e'
+ '11161582d9050710ccfecbe077fc5a63'
+ 'ac8f20b0cd83acb9525b5557e1fafeaf'
'82496e68851d1960543a07ba51cdb44a'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
'04b21c79df0a952c22d681dd4f4562df'
'9d3c56a4b999c8bfbd4018089a62f662'
- '263725f20c0b9eb9c353040792d644e5'
- '80a46681386bb87813989faeb92bdd9a'
- '4537ac9f15f96430c431d0ac22f43b80')
+ '670931649c60fcb3ef2e0119ed532bd4'
+ '8a71abc4224f575008f974a099b5cf6f'
+ 'a281ee5d89a016d72840bddb2d742635')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -71,24 +71,16 @@ build() {
# Add freedo as boot logo
patch -Np1 -i "${srcdir}/boot-logo.patch"
- # Some chips detect a ghost TV output
- # mailing list discussion: http://lists.freedesktop.org/archives/intel-gfx/2011-April/010371.html
- # Arch Linux bug report: FS#19234
- #
- # It is unclear why this patch wasn't merged upstream, it was accepted,
- # then dropped because the reasoning was unclear. However, it is clearly
- # needed.
- patch -Np1 -i "${srcdir}/i915-fix-ghost-tv-output.patch"
-
- # Fix backlight control on some laptops:
- # https://bugzilla.kernel.org/show_bug.cgi?id=43168
- patch -Np1 -i "${srcdir}/3.4.4-fix-backlight-regression.patch"
-
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
+ # fix module initialisation
+ # https://bugs.archlinux.org/task/32122
+ patch -Np1 -i "${srcdir}/module-symbol-waiting-3.6.patch"
+ patch -Np1 -i "${srcdir}/module-init-wait-3.6.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre-rt|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \
@@ -101,7 +93,7 @@ build() {
# https://git.kernel.org/?p=linux/hotplug/udev.git;a=blob_plain;f=README
# and make USB storage support builtin (e.g. for booting from USB
# disks without slowly loading an initramfs)
- sed -ri -e "s|CONFIG_MIPS32_N32=.*|CONFIG_MIPS32_N32=y|g" \
+ sed -ri \
-e "s|CONFIG_MIPS32_N32=.*|CONFIG_MIPS32_N32=y|g" \
-e "s|CONFIG_UEVENT_HELPER_PATH=.*|CONFIG_UEVENT_HELPER_PATH=\"\"|g" \
-e "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_localversionname}\"|g" \
@@ -165,7 +157,7 @@ build() {
_package() {
pkgdesc="The ${pkgbase} kernel and modules with realtime preemption"
[ "${pkgbase}" = "linux-libre" ] && groups=('base')
- depends=('coreutils' 'kmod')
+ depends=('coreutils' 'linux-libre-firmware' 'kmod')
optdepends=('crda: to set the correct wireless channels of your country')
provides=("kernel26${_kernelname}=${pkgver}" "linux${_kernelname}=${pkgver}")
conflicts=("kernel26${_kernelname}" "kernel26-libre${_kernelname}" "linux${_kernelname}")