summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-pae/PKGBUILD')
-rw-r--r--kernels/linux-libre-pae/PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/kernels/linux-libre-pae/PKGBUILD b/kernels/linux-libre-pae/PKGBUILD
index 2941d7fd1..0874a651a 100644
--- a/kernels/linux-libre-pae/PKGBUILD
+++ b/kernels/linux-libre-pae/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 203524 2014-01-12 13:05:55Z tpowa $
+# $Id: PKGBUILD 204911 2014-01-31 09:59:51Z bluewind $
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -6,7 +6,7 @@
pkgbase=linux-libre-pae # Build stock -LIBRE-PAE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.12
-pkgver=${_basekernel}.7
+pkgver=${_basekernel}.9
pkgrel=2
arch=('i686')
url="http://linux-libre.fsfla.org/"
@@ -27,9 +27,10 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'nfs-check-gssd-running-before-krb5i-auth.patch'
'rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-fails.patch'
'sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch'
- 'rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch')
+ 'rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch'
+ '0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch')
md5sums=('254f59707b6676b59ce5ca5c3c698319'
- 'c42ff446236915fe1a6e2b6f9724d267'
+ '348975e36e4dd27f5d8fc50e92de8922'
'2c07956936879d8729ad68d997a79bbf'
'f302c931bd85309da9d9792b4cc96467'
'44260d2cb1a8b51c119d2ce1f83e457a'
@@ -40,7 +41,8 @@ md5sums=('254f59707b6676b59ce5ca5c3c698319'
'88eef9d3b5012ef7e82af1af8cc4e517'
'cec0bb8981936eab2943b2009b7a6fff'
'88d9cddf9e0050a76ec4674f264fb2a1'
- 'cb9016630212ef07b168892fbcfd4e5d')
+ 'cb9016630212ef07b168892fbcfd4e5d'
+ '336d2c4afd7ee5f2bdf0dcb1a54df4b2')
_kernelname=${pkgbase#linux-libre}
_localversionname=-LIBRE-PAE
@@ -58,6 +60,9 @@ prepare() {
# fix issue on Hal8188EFWImg_CE.c deblobbed file
sed -i "\|DEBLOBBED| s|,||" drivers/staging/rtl8188eu/hal/Hal8188EFWImg_CE.c
+ # add latest fixes from stable queue, if needed
+ # http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -67,7 +72,7 @@ prepare() {
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
- # fix 15 seocnds nfs delay
+ # fix 15 seconds nfs delay
patch -Np1 -i "${srcdir}/sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch"
patch -Np1 -i "${srcdir}/sunrpc-replace-gssd_running-with-more-reliable-check.patch"
patch -Np1 -i "${srcdir}/nfs-check-gssd-running-before-krb5i-auth.patch"
@@ -78,6 +83,9 @@ prepare() {
patch -Np1 -i "${srcdir}/rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch"
+ # Fix CVE-2014-0038
+ patch -p1 -i "${srcdir}/0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch"
+
cat "${srcdir}/config" > ./.config # simpler
if [ "${_kernelname}" != "" ]; then