summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-grsec/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-grsec/PKGBUILD')
-rw-r--r--kernels/linux-libre-grsec/PKGBUILD27
1 files changed, 25 insertions, 2 deletions
diff --git a/kernels/linux-libre-grsec/PKGBUILD b/kernels/linux-libre-grsec/PKGBUILD
index f0d01f56b..7d60c6570 100644
--- a/kernels/linux-libre-grsec/PKGBUILD
+++ b/kernels/linux-libre-grsec/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 203405 2014-01-10 08:45:42Z tpowa $
+# $Id: PKGBUILD 203524 2014-01-12 13:05:55Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -14,7 +14,7 @@ _sublevel=7
_grsecver=3.0
_timestamp=201401091837
pkgver=${_basekernel}.${_sublevel}
-pkgrel=1
+pkgrel=2
_lxopkgver=${_basekernel}.7 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
@@ -33,6 +33,12 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'criu-no-expert.patch'
+ 'sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch'
+ 'sunrpc-replace-gssd_running-with-more-reliable-check.patch'
+ 'nfs-check-gssd-running-before-krb5i-auth.patch'
+ 'rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-fails.patch'
+ 'sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch'
+ 'rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch'
'module-blacklist.conf'
'sysctl.conf'
'known-exploit-detection.patch'
@@ -48,6 +54,12 @@ md5sums=('254f59707b6676b59ce5ca5c3c698319'
'14bb375a8a1d86d2875f72fcbaa03f3e'
'0892ce6045478bea4a005a6d82c0819e'
'b5509f6c3889a1b32f2e1f90ee2508f1'
+ 'd4a75f77e6bd5d700dcd534cd5f0dfce'
+ 'dc86fdc37615c97f03c1e0c31b7b833a'
+ '88eef9d3b5012ef7e82af1af8cc4e517'
+ 'cec0bb8981936eab2943b2009b7a6fff'
+ '88d9cddf9e0050a76ec4674f264fb2a1'
+ 'cb9016630212ef07b168892fbcfd4e5d'
'f93ef6157fbb23820bd5ae08fd3f451e'
'0db7629711f4ed76bd1f9da9f97bc4ea'
'34f7e421a25ebc3c1406e04db56accfa'
@@ -87,6 +99,17 @@ prepare() {
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
+ # fix 15 seocnds nfs delay
+ patch -Np1 -i "${srcdir}/sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch"
+ patch -Np1 -i "${srcdir}/sunrpc-replace-gssd_running-with-more-reliable-check.patch"
+ patch -Np1 -i "${srcdir}/nfs-check-gssd-running-before-krb5i-auth.patch"
+ # fix nfs kernel oops
+ # #37866
+ patch -Np1 -i "${srcdir}/rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-fails.patch"
+ patch -Np1 -i "${srcdir}/sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch"
+
+ patch -Np1 -i "${srcdir}/rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch"
+
# add known exploit detection patch
# http://lkml.org/lkml/2013/12/12/358
patch -Np1 -i "${srcdir}/known-exploit-detection.patch"