summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-grsec/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-grsec/PKGBUILD')
-rw-r--r--kernels/linux-libre-grsec/PKGBUILD39
1 files changed, 19 insertions, 20 deletions
diff --git a/kernels/linux-libre-grsec/PKGBUILD b/kernels/linux-libre-grsec/PKGBUILD
index b5aad3bbb..8f83b01e3 100644
--- a/kernels/linux-libre-grsec/PKGBUILD
+++ b/kernels/linux-libre-grsec/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 206177 2014-02-20 22:43:41Z thomas $
+# $Id: PKGBUILD 206252 2014-02-22 22:54:25Z thomas $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -10,12 +10,12 @@
pkgbase=linux-libre-grsec # Build stock -LIBRE-GRSEC kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.13
-_sublevel=4
+_sublevel=5
_grsecver=3.0
-_timestamp=201402201908
+_timestamp=201402241943
pkgver=${_basekernel}.${_sublevel}
pkgrel=1
-_lxopkgver=${_basekernel}.3 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.5 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -39,16 +39,17 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'0004-rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-.patch'
'0005-sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch'
'0006-rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-no.patch'
- '0001-SUNRPC-Ensure-that-gss_auth-isn-t-freed-before-its-u.patch'
'0001-syscalls.h-use-gcc-alias-instead-of-assembler-aliase.patch'
- '0001-quirk-asm_volatile_goto.patch'
'i8042-fix-aliases.patch'
+ 'module-blacklist.conf'
+ 'sysctl.conf'
+ 'known-exploit-detection.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
md5sums=('98a8e803e0ed08557f3cdd4d56b0ddc1'
- '3659d30b1d06dd5b7874ae04c946863b'
- '98bb51189e0fe96a10362ddcbb79a134'
- 'a2718a1b47c6c3b0774ce786488d22c3'
- 'cbe58a543b96ae282c674875b1940e59'
+ '6e59a1e4b891ca5fa8b03d488fa64e04'
+ '810f3caa18b89eda5b41a2cff5821a4a'
+ '21da34d98cc007a78a11660863537c0d'
+ 'd4b95575b9cc32b7ba4ad8624972ddf9'
'5f66bed97a5c37e48eb2f71b2d354b9a'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
@@ -61,11 +62,12 @@ md5sums=('98a8e803e0ed08557f3cdd4d56b0ddc1'
'10dbaf863e22b2437e68f9190d65c861'
'd5907a721b97299f0685c583499f7820'
'a724515b350b29c53f20e631c6cf9a14'
- '1ae4ec847f41fa1b6d488f956e94c893'
'e6fa278c092ad83780e2dd0568e24ca6'
- '6baa312bc166681f48e972824f3f6649'
'93dbf73af819b77f03453a9c6de2bb47'
- 'ac92b702b8497d2be14f96e077a7f48f')
+ 'f93ef6157fbb23820bd5ae08fd3f451e'
+ '0db7629711f4ed76bd1f9da9f97bc4ea'
+ 'cb789bf97bc65fd4cf240d99df9c24c0'
+ '5fcb6203b54aaf7dcbdf6e2c6f159b14')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -116,18 +118,15 @@ prepare() {
# http://git.linux-nfs.org/?p=trondmy/linux-nfs.git;a=commitdiff;h=23e66ba97127ff3b064d4c6c5138aa34eafc492f
patch -p1 -i "${srcdir}/0006-rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-no.patch"
- # Fix FS#38921
- # http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9eb2ddb48ce3a7bd745c14a933112994647fa3cd
- patch -p1 -i "${srcdir}/0001-SUNRPC-Ensure-that-gss_auth-isn-t-freed-before-its-u.patch"
-
# Fix symbols: Revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=83460ec8dcac14142e7860a01fa59c267ac4657c
patch -Rp1 -i "${srcdir}/0001-syscalls.h-use-gcc-alias-instead-of-assembler-aliase.patch"
# Fix i8042 aliases
patch -p1 -i "${srcdir}/i8042-fix-aliases.patch"
- # Fix compile issues
- # http://git.kernel.org/cgit/linux/kernel/git/tip/tip.git/patch/?id=a9f180345f5378ac87d80ed0bea55ba421d83859
- patch -Np1 -i "${srcdir}/0001-quirk-asm_volatile_goto.patch"
+
+ # add known exploit detection patch
+ # http://lkml.org/lkml/2013/12/12/358
+ patch -Np1 -i "${srcdir}/known-exploit-detection.patch"
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre-grsec|" Makefile