summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-aufs_friendly/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-aufs_friendly/PKGBUILD')
-rw-r--r--kernels/linux-libre-aufs_friendly/PKGBUILD59
1 files changed, 24 insertions, 35 deletions
diff --git a/kernels/linux-libre-aufs_friendly/PKGBUILD b/kernels/linux-libre-aufs_friendly/PKGBUILD
index 41ccc96bb..711ffcb92 100644
--- a/kernels/linux-libre-aufs_friendly/PKGBUILD
+++ b/kernels/linux-libre-aufs_friendly/PKGBUILD
@@ -8,29 +8,22 @@
# Maintainer (Parabola): Michał Masłowski <mtjm@mtjm.eu>
# Contributor (Parabola): Márcio Silva <coadde@adinet.com.uy>
-# In order to just get linux-libre as it used to be, with the exported symbols for AUFS-libre:
-
-# Uncomment these lines
-# pkgname=('linux-libre' 'linux-libre-headers' 'linux-libre-docs') # Build stock -LIBRE kernel
-# pkgname=linux-custom # Build kernel with a different name
-# pkgbase=linux-libre
-
-# Comment this line
+pkgbase=linux-libre-aufs_friendly
pkgname=('linux-libre-aufs_friendly' 'linux-libre-aufs_friendly-headers') # Build stock -LIBRE kernel with AUFS-libre support
-
+# pkgname=linux-custom # Build kernel with a different name
_kernelname=-LIBRE-AUFS_FRIENDLY
-_basekernel=3.2
-_sublevel=9
+_basekernel=3.3
+_sublevel=4
pkgver=${_basekernel}.${_sublevel}
-_lxopkgver=${_basekernel}.7 # nearly always the same as pkgver
-pkgrel=2
+_lxopkgver=${_basekernel}.4 # nearly always the same as pkgver
+pkgrel=1
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl')
options=('!strip')
-source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-libre/linux-${_basekernel}-libre.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre/patch-${_basekernel}-libre-${pkgver}-libre.xz"
+source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
+ "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
# the main kernel config files
'config.i686' 'config.x86_64'
# patches exporting symbols for the aufs module (reason for this package)
@@ -42,15 +35,14 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-li
'boot-logo.patch'
'change-default-console-loglevel.patch'
'i915-fix-ghost-tv-output.patch'
- 'i915-gpu-finish.patch'
'ext4-options.patch'
- "http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/linux-patches-${_lxopkgver}-libre-lemote_0lxo_mipsel.tar.bz2")
-md5sums=('27c641c4f6785fc647cdd3e44963a55c'
- '8e601878ccdd37111cc84500ebd81387'
- '1e5dd328dbf4e68072a22c05c18813c7'
- '6f9df3879268e0f07f535db2b6197475'
- '44a5461daf301a46adf20c475069aaa7'
- '9c1d9e47a0991b9d3d1f1ede01171c04'
+ "http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
+md5sums=('5487da14ca81715a469c7594d39722fa'
+ 'ce7d959667b9f158b1fb814b5806950a'
+ '9824d09d2a659db17a6468e27ccc29ad'
+ '2ffd4a4dbd5dbc16c378befd6917b7f5'
+ '753713a00d3150ee1e03f33d97326100'
+ 'f78455bd6fabaae14bc98d83baf8bfa9'
'318ce8b3b64e4923a840817b91035753'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
@@ -59,7 +51,7 @@ md5sums=('27c641c4f6785fc647cdd3e44963a55c'
'263725f20c0b9eb9c353040792d644e5'
'4cd79aa147825837dc8bc9f6b736c0a0'
'f36222e7ce20c8e4dc27376f9be60f6c'
- '690e6201d219638544d2fba3996dc822')
+ 'c22b03a6351698b07cd08767d8ddeacd')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -70,16 +62,12 @@ build() {
cd "${srcdir}/linux-${_basekernel}"
if [ "${_basekernel}" != "${pkgver}" ]; then
- patch -Np1 -i "${srcdir}/patch-${_basekernel}-libre-${pkgver}-libre"
+ patch -Np1 -i "${srcdir}/patch-${_basekernel}-gnu-${pkgver}-gnu"
fi
# Add freedo as boot logo
patch -Np1 -i "${srcdir}/boot-logo.patch"
- # fix FS#27883
- # drm/i915: Only clear the GPU domains upon a successful finish
- patch -Np1 -i "${srcdir}/i915-gpu-finish.patch"
-
# Some chips detect a ghost TV output
# mailing list discussion: http://lists.freedesktop.org/archives/intel-gfx/2011-April/010371.html
# Arch Linux bug report: FS#19234
@@ -89,19 +77,20 @@ build() {
# needed.
patch -Np1 -i "${srcdir}/i915-fix-ghost-tv-output.patch"
+ # Patch submitted upstream, waiting for inclusion:
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
- msg 'AUFS3-libre patches'
- patch -p1 -i "${srcdir}/aufs3-libre-base.patch"
- patch -p1 -i "${srcdir}/aufs3-libre-standalone.patch"
-
# fix ext4 module to mount ext3/2 correct
# https://bugs.archlinux.org/task/28653
patch -Np1 -i "${srcdir}/ext4-options.patch"
+ msg 'AUFS3-libre patches'
+ patch -p1 -i "${srcdir}/aufs3-libre-base.patch"
+ patch -p1 -i "${srcdir}/aufs3-libre-standalone.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \
@@ -117,7 +106,7 @@ build() {
sed -ri -e "s|CONFIG_MIPS32_N32=.*|CONFIG_MIPS32_N32=y|g" \
-e "s|CONFIG_MIPS32_N32=.*|CONFIG_MIPS32_N32=y|g" \
-e "s|CONFIG_UEVENT_HELPER_PATH=.*|CONFIG_UEVENT_HELPER_PATH=\"\"|g" \
- -e "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"-LIBRE\"|g" \
+ -e "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" \
-e "s;(CONFIG_USB(_COMMON|_EHCI_HCD|_OHCI_HCD|_STORAGE.*|_UAS)?)=.*;\1=y;g" \
./.config
else
@@ -261,7 +250,7 @@ package_linux-libre-aufs_friendly-headers() {
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include"
for i in acpi asm-generic config crypto drm generated linux math-emu \
- media net pcmcia scsi sound trace video xen; do
+ media mtd net pcmcia scsi sound trace video xen; do
cp -a include/${i} "${pkgdir}/usr/src/linux-${_kernver}/include/"
done