summaryrefslogtreecommitdiff
path: root/cross/cross-mips64el-unknown-linux-gnu-glibc-headers/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'cross/cross-mips64el-unknown-linux-gnu-glibc-headers/PKGBUILD')
-rw-r--r--cross/cross-mips64el-unknown-linux-gnu-glibc-headers/PKGBUILD380
1 files changed, 291 insertions, 89 deletions
diff --git a/cross/cross-mips64el-unknown-linux-gnu-glibc-headers/PKGBUILD b/cross/cross-mips64el-unknown-linux-gnu-glibc-headers/PKGBUILD
index 9b03da6d7..33839012a 100644
--- a/cross/cross-mips64el-unknown-linux-gnu-glibc-headers/PKGBUILD
+++ b/cross/cross-mips64el-unknown-linux-gnu-glibc-headers/PKGBUILD
@@ -8,54 +8,91 @@ _pkgname=glibc
_target="mips64el-unknown-linux-gnu"
_sysroot="/usr/${_target}"
_ARCH=mips
+_CFLAGS=" -EL -march=loongson2f -mabi=n32 -O2 -U_FORTIFY_SOURCE " \
unset CFLAGS CXXFLAGS LDFLAGS
pkgname=cross-${_target}-glibc-headers
pkgver=2.15
-pkgrel=4
+pkgrel=10
_glibcdate=20111227
+_glibcportsver=2.15
+_glibcportsdate=20120127
pkgdesc="GNU C Library"
arch=('i686' 'x86_64' 'mips64el')
url="http://www.gnu.org/software/libc"
license=('GPL' 'LGPL')
groups=("${_target}-devel")
-depends=("${_target}-linux-api-headers>=3.1.6" 'tzdata')
+depends=("${_target}-linux-libre-api-headers>=3.3" 'tzdata')
makedepends=("${_target}-binutils"
"cross-${_target}-gcc-core")
options=('!strip')
install=glibc.install
source=(ftp://ftp.archlinux.org/other/glibc/${_pkgname}-${pkgver}_${_glibcdate}.tar.xz
- http://repo.parabolagnulinux.org/other/glibc-ports-${pkgver}_${_glibcdate}.tar.xz
- configure.patch
- glibc-2.10-dont-build-timezone.patch
- glibc-2.10-bz4781.patch
+ http://repo.parabolagnulinux.org/other/glibc-ports-${_glibcportsver}_${_glibcportsdate}.tar.xz
+ glibc-2.15-do-not-install-timezone-files.patch
+ glibc-2.15-do-not-install-timezone-files-2.patch
glibc-__i686.patch
glibc-2.12.2-ignore-origin-of-privileged-program.patch
glibc-2.14-libdl-crash.patch
- glibc-2.14-revert-4768ae77.patch
glibc-2.14-reexport-rpc-interface.patch
glibc-2.14-reinstall-nis-rpc-headers.patch
+ glibc-2.15-fix-res_query-assert.patch
+ glibc-2.15-regex.patch
glibc-2.15-lddebug-scopes.patch
glibc-2.15-revert-c5a0802a.patch
- glibc-2.15-math64crash.patch
+ glibc-2.15-scanf.patch
+ glibc-2.15-ifunc.patch
+ glibc-2.15-avx.patch
+ glibc-2.15-strcasecmp-disable-avx.patch
+ glibc-2.15-gb18030.patch
+ glibc-2.15-revert-netlink-cache.patch
+ glibc-2.15-arena.patch
+ glibc-2.15-negative-result-cache.patch
+ glibc-2.15-multiarch-x86-strcmp.patch
+ glibc-2.15-vdso.patch
+ glibc-2.15-feraiseexcept-plt.patch
+ glibc-2.15-vfprintf-nargs.patch
+ glibc-2.15-__libc_res_nquerydomain-out-of-bounds.patch
+ glibc-2.15-fmtmsg-locking.patch
+ glibc-2.15-non-signalling-comparisons.patch
+ glibc-2.15-rintf-rounding.patch
+ glibc-2.15-nearbyintf-rounding.patch
+ glibc-2.15-confstr-local-buffer-extent.patch
nscd
locale.gen.txt
locale-gen)
md5sums=('6ffdf5832192b92f98bdd125317c0dfc'
- 'a006504b83553d0b554cf8badff005b6'
- '39f80ba6bcda6b010a66f9c61e9a0017'
- '4dadb9203b69a3210d53514bb46f41c3'
- '0c5540efc51c0b93996c51b57a8540ae'
- '40cd342e21f71f5e49e32622b25acc52'
- 'b042647ea7d6f22ad319e12e796bd13e'
+ '935995663b89924a98d20a636045949a'
+ '7ef69c530a15106de93e4de2df2d393e'
+ 'b6c619e5cf91829a15ce34dccef676d5'
+ 'addfddd648a4bf832eb126aba944ebae'
+ 'e60e33591c9ec1447e4cddadcbb9cf3a'
'6970bcfeb3bf88913436d5112d16f588'
- '7da8c554a3b591c7401d7023b1928afc'
'c5de2a946215d647c8af5432ec4b0da0'
'55febbb72139ac7b65757df085024b83'
+ '31f415b41197d85d3bbee3d1eecd06a3'
+ 'b3526cbd5e29773560dba725db99af5a'
'3c219ddfb619b6df903cac4cc42c611d'
'7ae3e426251ae33e73dbad71f9c91378'
- 'dc7550e659ddd685bd78a930d15a01f2'
+ 'f0782ddbf38e0b30ec6b85348816046f'
+ '3d844b53b2dbb7c996e39c7ad932f55d'
+ '41ae047ac88e8f6f547c70b0a0bc3b72'
+ 'fccb89f6628f59752278e125c35941f8'
+ 'c4cd34f20ccd37817f6c1374bd4ee68e'
+ '94b61302a7ca6c5764d013dc7738fcfe'
+ 'a9ffadcfd2d357f91fee0b861fd4a7c6'
+ '2c46b8e294de24c531f2253ff69aeef3'
+ '7a2998a04ebfcf8bf820540f490ce714'
+ '0d77d20fa7fe2f87ad945cb9edb4d91d'
+ 'bfdefac3d705f41fbf84b1de1dc945af'
+ '3443e89c1e98089cd6c3e3c23f0c3d85'
+ '340deaa582a95ddde86edb624c3bfea0'
+ '6bbac50e6ff82187654e6a0a7bd849e7'
+ 'c483504cf404ed0b44480af627813a97'
+ '1419d61fd1dbc6cdc48bb59da86fa66f'
+ '7ff501435078b1a2622124fbeaafc921'
+ '8d1023a51e0932681b46440d5f8551ee'
'b587ee3a70c9b3713099295609afde49'
'07ac979b6ab5eeb778d55f041529d623'
'476e9113489f93b348b21e144b6a8fcf')
@@ -71,96 +108,227 @@ mksource() {
}
mksource-ports() {
- tsocks git clone git://sourceware.org/git/glibc-ports.git
+ git clone http://sourceware.org/git/glibc-ports.git
pushd glibc-ports
- git checkout -b glibc-${pkgver}-arch origin/release/${pkgver}/master
+ git checkout -b glibc-${_glibcportsver}-arch origin/release/${_glibcportsver}/master
popd
- tar -cvJf glibc-ports-${pkgver}_${_glibcdate}.tar.xz glibc-ports/*
+ tar -cvJf glibc-ports-${_glibcportsver}_${_glibcportsdate}.tar.xz glibc-ports/*
}
+
build() {
cd ${srcdir}/glibc
- # export PATH=${_sysroot}/bin/:$PATH
-
- # timezone data is in separate package (tzdata)
- patch -Np1 -i ${srcdir}/glibc-2.10-dont-build-timezone.patch
-
- # http://sources.redhat.com/bugzilla/show_bug.cgi?id=4781
- patch -Np1 -i ${srcdir}/glibc-2.10-bz4781.patch
-
- # http://sources.redhat.com/bugzilla/show_bug.cgi?id=411
- # http://sourceware.org/ml/libc-alpha/2009-07/msg00072.html
- patch -Np1 -i ${srcdir}/glibc-__i686.patch
-
- # http://www.exploit-db.com/exploits/15274/
- # http://sourceware.org/git/?p=glibc.git;a=patch;h=d14e6b09 (only fedora branch...)
- patch -Np1 -i ${srcdir}/glibc-2.12.2-ignore-origin-of-privileged-program.patch
-
- # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=675155e9 (only fedora branch...)
- # http://sourceware.org/ml/libc-alpha/2011-06/msg00006.html
- patch -Np1 -i ${srcdir}/glibc-2.14-libdl-crash.patch
+ # timezone data is in separate package (tzdata)
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=482ff4da
+ patch -p1 -i ${srcdir}/glibc-2.15-do-not-install-timezone-files.patch
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=a458e7fe
+ patch -p1 -i ${srcdir}/glibc-2.15-do-not-install-timezone-files-2.patch
+
+ # undefine __i686
+ # http://sourceware.org/glibc/wiki/Release/2.15#Build_Failures
+ patch -p1 -i ${srcdir}/glibc-__i686.patch
+
+ # http://www.exploit-db.com/exploits/15274/
+ # http://sourceware.org/git/?p=glibc.git;a=patch;h=d14e6b09 (fedora branch)
+ patch -p1 -i ${srcdir}/glibc-2.12.2-ignore-origin-of-privileged-program.patch
+
+ # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=675155e9 (fedora branch)
+ # http://sourceware.org/ml/libc-alpha/2011-06/msg00006.html
+ patch -p1 -i ${srcdir}/glibc-2.14-libdl-crash.patch
+
+ # re-export RPC interface until libtirpc is ready as a replacement
+ # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=acee4873 (fedora branch)
+ patch -p1 -i ${srcdir}/glibc-2.14-reexport-rpc-interface.patch
+ # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=bdd816a3 (fedora branch)
+ patch -p1 -i ${srcdir}/glibc-2.14-reinstall-nis-rpc-headers.patch
+
+ # fix res_query assertion
+ # http://sourceware.org/bugzilla/show_bug.cgi?id=13013
+ patch -p1 -i ${srcdir}/glibc-2.15-fix-res_query-assert.patch
+
+ # fix up regcomp/regexec
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=2ba92745
+ patch -p1 -i ${srcdir}/glibc-2.15-regex.patch
+
+ # propriety nvidia crash - https://bugzilla.redhat.com/show_bug.cgi?id=737223
+ # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=0c95ab64 (fedora branch)
+ patch -p1 -i ${srcdir}/glibc-2.15-lddebug-scopes.patch
+
+ # revert commit c5a0802a - causes various hangs
+ # https://bugzilla.redhat.com/show_bug.cgi?id=769421
+ # Note: fedora may have actual fix (not submitted upstream yet...)
+ # http://pkgs.fedoraproject.org/gitweb/?p=glibc.git;a=blob_plain;f=glibc-rh552960-2.patch
+ patch -p1 -i ${srcdir}/glibc-2.15-revert-c5a0802a.patch
+
+ # fix realloc usage in vfscanf
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=20b38e03
+ patch -p1 -i ${srcdir}/glibc-2.15-scanf.patch
+
+ # fix ifunc relocations
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=6ee65ed6
+ patch -p1 -i ${srcdir}/glibc-2.15-ifunc.patch
+
+ # fix AVX detection
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=afc5ed09
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=08cf777f
+ patch -p1 -i ${srcdir}/glibc-2.15-avx.patch
+ # and "fix" strcasecmp
+ patch -p1 -i ${srcdir}/glibc-2.15-strcasecmp-disable-avx.patch
+
+ # fix GB18030 charmap
+ # http://sourceware.org/bugzilla/show_bug.cgi?id=11837
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=2a57bd79 (fedora branch)
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=3d828a61 (fedora branch)
+ patch -p1 -i ${srcdir}/glibc-2.15-gb18030.patch
+
+ # fix crash in __nscd_get_mapping if nscd not running
+ # http://sourceware.org/bugzilla/show_bug.cgi?id=13594 (potential "fix" in comment)
+ # reverts commit 3a2c0242 and other necessary following changes...
+ patch -p1 -i ${srcdir}/glibc-2.15-revert-netlink-cache.patch
+
+ # handle ARENA_TEST correctly
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=41b81892
+ patch -p1 -i ${srcdir}/glibc-2.15-arena.patch
+
+ # Do not cache negative results in nscd if these are transient
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=3e1aa84e
+ patch -p1 -i ${srcdir}/glibc-2.15-negative-result-cache.patch
+
+ # strcasecmp_l, strncasecmp_l act as strcmp for multiarch x86
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=0bab47b6
+ patch -p1 -i ${srcdir}/glibc-2.15-multiarch-x86-strcmp.patch
+
+ # always set l_used for vDSO.
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=1f393a11
+ patch -p1 -i ${srcdir}/glibc-2.15-vdso.patch
+
+ # fix x86 PLT slot usage for feraiseexcept
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=7c35ffed
+ patch -p1 -i ${srcdir}/glibc-2.15-feraiseexcept-plt.patch
+
+ # vfprintf nargs overflow - CVE-2012-0864
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=7c1f4834
+ patch -p1 -i ${srcdir}/glibc-2.15-vfprintf-nargs.patch
+
+ # avoid out ouf bounds read in __libc_res_nquerydomain
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=8fdceb2e
+ patch -p1 -i ${srcdir}/glibc-2.15-__libc_res_nquerydomain-out-of-bounds.patch
+
+ # make fmtmsg function thread-safe
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=7724defc
+ patch -p1 -i ${srcdir}/glibc-2.15-fmtmsg-locking.patch
+
+ # use non-signaling floating-point comparisons in math functions
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=92221550
+ patch -p1 -i ${srcdir}/glibc-2.15-non-signalling-comparisons.patch
+
+ # fix rintf rounding.
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=fe45ce09
+ patch -p1 -i ${srcdir}/glibc-2.15-rintf-rounding.patch
+
+ # fix nearbyintf rounding
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=6cbeae47
+ patch -p1 -i ${srcdir}/glibc-2.15-nearbyintf-rounding.patch
- # Revert commit causing issues with crappy DNS servers...
- # Will be removed when workaround becomes annoying to maintain - USE A BETTER DNS SERVER!
- # Note that both these patches appear not to fix the issue completely:
- # http://sourceware.org/bugzilla/show_bug.cgi?id=13013
- # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=032c0ee3 (only fedora branch...)
- patch -Np1 -i ${srcdir}/glibc-2.14-revert-4768ae77.patch
-
- # re-export RPC interface until libtirpc is ready as a replacement
- # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=acee4873 (only fedora branch...)
- patch -Np1 -i ${srcdir}/glibc-2.14-reexport-rpc-interface.patch
- # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=bdd816a3 (only fedora branch...)
- patch -Np1 -i ${srcdir}/glibc-2.14-reinstall-nis-rpc-headers.patch
-
- # propriety nvidia crash - https://bugzilla.redhat.com/show_bug.cgi?id=737223
- # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=0c95ab64 (only fedora branch...)
- patch -Np1 -i ${srcdir}/glibc-2.15-lddebug-scopes.patch
-
- # revert commit c5a0802a - causes various hangs
- # https://bugzilla.redhat.com/show_bug.cgi?id=769421
- patch -Np1 -i ${srcdir}/glibc-2.15-revert-c5a0802a.patch
+ ln -s ../glibc-ports ports
- # revert optimized math routines that can cause crashes (FS#27736, FS#27743)
- # obviously not a real fix...
- patch -Np1 -i ${srcdir}/glibc-2.15-math64crash.patch
+ if [ "${_target}" = "mips64el-unknown-linux-gnu" ]; then
+ # Fix typo making util-linux build fail.
+ sed -i "s/_MIPS_SIM_ABIN32/_MIPS_SIM_NABI32/" ports/sysdeps/unix/sysv/linux/mips/Makefile
+ # mips64el is only supported out of tree.
+ extra_addons=",ports"
+ fi
- patch -Np0 -i ${srcdir}/configure.patch
+ # fix varaible scope issue in confstr
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=ac4c54f0
+ # http://sourceware.org/git/?p=glibc.git;a=commit;h=d6a403f9
+ patch -p1 -i ${srcdir}/glibc-2.15-confstr-local-buffer-extent.patch
- ln -s ../glibc-ports ports
+# patch -Np0 -i ${srcdir}/configure.patch
+ install -dm755 ${pkgdir}/etc
+ touch ${pkgdir}/etc/ld.so.conf
cd ${srcdir}
mkdir glibc-build
cd glibc-build
- echo "libc_cv_ctors_header=no" >> config.cache
- echo "libc_cv_forced_unwind=yes" >> config.cache
- echo "libc_cv_c_cleanup=yes" >> config.cache
-
- BUILD_CC=${CHOST}-gcc \
- CFLAGS=" -EL -march=loongson2f -mabi=n32 -O2 -U_FORTIFY_SOURCE " \
- CC=${_target}-gcc \
- AR=${_target}-ar \
- RANLIB=${_target}-ranlib \
- ${srcdir}/glibc/configure \
- --prefix=/usr \
- --build=${CHOST} \
- --host=${_target} \
- --without-cvs \
- --disable-profile \
- --without-gd \
- --with-headers=/usr/${_target}/usr/include \
- --cache-file=${srcdir}/glibc-build/config.cache \
- --disable-debug \
- --disable-sanity-checks \
- --enable-kernel=2.6.27 \
- --with-__thread \
- --with-tls \
- --enable-shared \
- --with-fp \
- --enable-add-ons=nptl,ports
+# echo "libc_cv_ctors_header=no" >> config.cache
+# echo "libc_cv_forced_unwind=yes" >> config.cache
+# echo "libc_cv_c_cleanup=yes" >> config.cache
+
+# BUILD_CC=${CHOST}-gcc \
+# CFLAGS=" -EL -march=loongson2f -mabi=n32 -O2 -U_FORTIFY_SOURCE " \
+# CC=${_target}-gcc \
+# AR=${_target}-ar \
+# RANLIB=${_target}-ranlib \
+# ${srcdir}/glibc/configure \
+# --prefix=/usr \
+# --build=${CHOST} \
+# --host=${_target} \
+# --without-cvs \
+# --disable-profile \
+# --without-gd \
+# --with-headers=/usr/${_target}/usr/include \
+# --cache-file=${srcdir}/glibc-build/config.cache \
+# --disable-debug \
+# --disable-sanity-checks \
+# --enable-kernel=2.6.27 \
+# --with-__thread \
+# --with-tls \
+# --enable-shared \
+# --with-fp \
+# --enable-add-ons=nptl,ports
+
+ if [[ ${CARCH} = "i686" ]]; then
+ # Hack to fix NPTL issues with Xen, only required on 32bit platforms
+ # TODO: make separate glibc-xen package for i686
+ export CFLAGS="${CFLAGS} -mno-tls-direct-seg-refs"
+ fi
+
+ echo "slibdir=${_sysroot}/usr/lib" >> configparms
+
+ # remove hardening options from CFLAGS for building libraries
+ CFLAGS=${CFLAGS/-fstack-protector/}
+ CFLAGS=${CFLAGS/-D_FORTIFY_SOURCE=2/}
+
+ BUILD_CC=${CHOST}-gcc \
+ CC=${_target}-gcc \
+ AR=${_target}-ar \
+ AS=${_target}-as \
+ RANLIB=${_target}-ranlib \
+ CFLAGS="${_CFLAGS}" \
+ ${srcdir}/glibc/configure --prefix=/usr \
+ --build=${CHOST} \
+ --host=${_target} \
+ --with-headers=${_sysroot}/usr/include \
+ --enable-add-ons=nptl,libidn$extra_addons \
+ --enable-kernel=2.6.32 \
+ --with-tls --with-__thread \
+ --enable-bind-now --without-gd \
+ --without-cvs --disable-profile \
+ --enable-multi-arch
+
+# # build libraries with hardening disabled
+# echo "build-programs=no" >> configparms
+# make
+#
+# # re-enable hardening for programs
+# sed -i "s#=no#=yes#" configparms
+# echo "CC += -fstack-protector -D_FORTIFY_SOURCE=2" >> configparms
+# echo "CXX += -fstack-protector -D_FORTIFY_SOURCE=2" >> configparms
+# make
+
+# # remove harding in preparation to run test-suite
+# sed -i '2,4d' configparms
+
+}
+
+check() {
+ cd ${srcdir}/glibc-build
+ # some errors are expected - manually check log files
+ make -k check || true
}
package() {
@@ -197,3 +365,37 @@ package() {
ln -s ${_sysroot}/usr/lib/libc.so ${pkgdir}${_sysroot}/lib/
}
+md5sums=('6ffdf5832192b92f98bdd125317c0dfc'
+ '344e06a320fd53b3f267bd4bfb3f681f'
+ '7ef69c530a15106de93e4de2df2d393e'
+ 'b6c619e5cf91829a15ce34dccef676d5'
+ 'bc4829f8e431bdb13e597633abdc626d'
+ 'e60e33591c9ec1447e4cddadcbb9cf3a'
+ '6970bcfeb3bf88913436d5112d16f588'
+ 'c5de2a946215d647c8af5432ec4b0da0'
+ '55febbb72139ac7b65757df085024b83'
+ '31f415b41197d85d3bbee3d1eecd06a3'
+ 'b3526cbd5e29773560dba725db99af5a'
+ '3c219ddfb619b6df903cac4cc42c611d'
+ '7ae3e426251ae33e73dbad71f9c91378'
+ 'f0782ddbf38e0b30ec6b85348816046f'
+ '3d844b53b2dbb7c996e39c7ad932f55d'
+ '41ae047ac88e8f6f547c70b0a0bc3b72'
+ 'fccb89f6628f59752278e125c35941f8'
+ 'c4cd34f20ccd37817f6c1374bd4ee68e'
+ '94b61302a7ca6c5764d013dc7738fcfe'
+ 'a9ffadcfd2d357f91fee0b861fd4a7c6'
+ '2c46b8e294de24c531f2253ff69aeef3'
+ '7a2998a04ebfcf8bf820540f490ce714'
+ '0d77d20fa7fe2f87ad945cb9edb4d91d'
+ 'bfdefac3d705f41fbf84b1de1dc945af'
+ '3443e89c1e98089cd6c3e3c23f0c3d85'
+ '340deaa582a95ddde86edb624c3bfea0'
+ '6bbac50e6ff82187654e6a0a7bd849e7'
+ 'c483504cf404ed0b44480af627813a97'
+ '1419d61fd1dbc6cdc48bb59da86fa66f'
+ '7ff501435078b1a2622124fbeaafc921'
+ '8d1023a51e0932681b46440d5f8551ee'
+ 'b587ee3a70c9b3713099295609afde49'
+ '07ac979b6ab5eeb778d55f041529d623'
+ '476e9113489f93b348b21e144b6a8fcf')