summaryrefslogtreecommitdiff
path: root/cross/cross-mips64el-unknown-linux-gnu-binutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'cross/cross-mips64el-unknown-linux-gnu-binutils/PKGBUILD')
-rw-r--r--cross/cross-mips64el-unknown-linux-gnu-binutils/PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/cross/cross-mips64el-unknown-linux-gnu-binutils/PKGBUILD b/cross/cross-mips64el-unknown-linux-gnu-binutils/PKGBUILD
index 82260cc58..d4d3afe38 100644
--- a/cross/cross-mips64el-unknown-linux-gnu-binutils/PKGBUILD
+++ b/cross/cross-mips64el-unknown-linux-gnu-binutils/PKGBUILD
@@ -2,14 +2,13 @@
_pkgname=binutils
_target="mips64el-unknown-linux-gnu"
-# We don't add the target because it duplicates it /usr/lib/$target/$target
-_sysroot="/usr/lib"
+_sysroot="/usr/${_target}"
unset CFLAGS CXXFLAGS LDFLAGS
pkgname=cross-${_target}-binutils
pkgver=2.22
-pkgrel=7
+pkgrel=11
pkgdesc="A set of programs to assemble and manipulate binary and object files for the MIPS architecture"
url="http://www.gnu.org/software/binutils/"
arch=('i686' 'x86_64')
@@ -26,13 +25,13 @@ build() {
./configure --build=${CHOST} \
--host=${CHOST} \
--target=${_target} \
- --prefix=${_sysroot} \
+ --prefix=/usr \
--disable-nls \
--disable-multilib \
--disable-werror \
--enable-ld=yes \
--enable-gold=no \
- --with-sysroot=${_sysroot}/${_target}
+ --with-sysroot=${_sysroot}
make
}
@@ -42,6 +41,5 @@ package() {
make DESTDIR=${pkgdir} install
- mv ${pkgdir}/usr/lib/lib/libiberty.a ${pkgdir}${_sysroot}/${_target}/lib/
- rm -r ${pkgdir}/usr/lib/lib ${pkgdir}/usr/lib/share
+ rm -r ${pkgdir}/usr/{lib,share}
}