summaryrefslogtreecommitdiff
path: root/~fauno/kyotocabinet/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-15 11:07:44 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-15 11:07:44 -0500
commitceb71fa7012f347bd15179693d2484c1b5418505 (patch)
tree1eca7f8923823f94aa9a6cd295d0c0017c47c059 /~fauno/kyotocabinet/PKGBUILD
parentb1c72d09dd64bffc2fa820bf0927623efc8a394f (diff)
parentecc0a835e2453a8d44a08883bcd3b3f753ffce47 (diff)
downloadabslibre-ceb71fa7012f347bd15179693d2484c1b5418505.tar.gz
abslibre-ceb71fa7012f347bd15179693d2484c1b5418505.tar.bz2
abslibre-ceb71fa7012f347bd15179693d2484c1b5418505.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to '~fauno/kyotocabinet/PKGBUILD')
-rw-r--r--~fauno/kyotocabinet/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/~fauno/kyotocabinet/PKGBUILD b/~fauno/kyotocabinet/PKGBUILD
new file mode 100644
index 000000000..1636bfda0
--- /dev/null
+++ b/~fauno/kyotocabinet/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexander Duscheleit <jinks@archlinux.us>
+# Contributor: Joaquim Pedro (osmano807) <osmano807@gmail.com>
+pkgname=kyotocabinet
+pkgver=1.2.76
+pkgrel=1
+pkgdesc="a modern implementation of DBM in C++"
+arch=('i686' 'x86_64')
+url="http://fallabs.com/kyotocabinet"
+license=('LGPL3')
+makedepends=('gcc>=3.1' 'make' 'pkgconfig' 'zlib')
+depends=('zlib' 'gcc-libs')
+source=("http://fallabs.com/${pkgname}/pkg/${pkgname}-${pkgver}.tar.gz")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make install DESTDIR="$pkgdir/"
+}
+sha512sums=('278db7b327eb4c21bf0137d9aa14fb67d74d5ce7ed1cb29fc9120d157a60de165ec0cf842903eb7952e8f998045ae585b958977fa973ba0e0773381de71d9f6a')