summaryrefslogtreecommitdiff
path: root/~emulatorman/mednafen-wip/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-02-26 21:53:52 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-02-26 21:53:52 -0500
commit7275399e96c64abc852c3746aa58d10bee8a5a44 (patch)
treea798ae34656585ec83f390dac95382ccc303919c /~emulatorman/mednafen-wip/PKGBUILD
parent4bfc44a83c098d0f6d731b855541140fac36b8aa (diff)
parent31763e92611731c859ccbe4e97019afabb5ef91e (diff)
downloadabslibre-7275399e96c64abc852c3746aa58d10bee8a5a44.tar.gz
abslibre-7275399e96c64abc852c3746aa58d10bee8a5a44.tar.bz2
abslibre-7275399e96c64abc852c3746aa58d10bee8a5a44.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/abslibre
Diffstat (limited to '~emulatorman/mednafen-wip/PKGBUILD')
-rwxr-xr-x~emulatorman/mednafen-wip/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/~emulatorman/mednafen-wip/PKGBUILD b/~emulatorman/mednafen-wip/PKGBUILD
new file mode 100755
index 000000000..93893684e
--- /dev/null
+++ b/~emulatorman/mednafen-wip/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Hans-Kristian Arntzen <maister@archlinux.us>
+# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+# Contributor: kagan <juanynie@mi.madritel.es>
+# Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
+
+pkgname=mednafen-wip
+pkgver=0.9.19
+pkgrel=1
+pkgdesc="A command-line multi-system gaming emulator, WIP version"
+url="http://mednafen.sourceforge.net/"
+license=(GPL)
+arch=('i686' 'x86_64')
+depends=('libcdio>=0.82' 'libsamplerate' 'libogg' 'libvorbis' 'sdl' 'sdl_net' 'libsndfile' 'zlib')
+makedepends=('pkgconfig' 'mesa')
+conflicts=('mednafen')
+provides=('mednafen')
+source=('http://forum.fobby.net/index.php?t=getfile&id=345&' 'build.patch')
+md5sums=('64be12196aa02828539af677b0e2a66c'
+ 'aac8957fa5274f00feed6a462fa8b7ad')
+
+build()
+{
+ cd $srcdir/mednafen
+ patch -p1 < $srcdir/build.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package()
+{
+ cd $srcdir/mednafen
+ make DESTDIR=$pkgdir install
+}
+