summaryrefslogtreecommitdiff
path: root/social/uci/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-03-04 17:11:15 -0200
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-03-04 17:11:15 -0200
commitb469fe846f9de0b81022844f8d847e4589a0b9fc (patch)
tree5449edacb4e5478324283db8ca183065ac443844 /social/uci/PKGBUILD
parentb5d60ba3a7cc358fbc4dcfa51ba110633627fb13 (diff)
parent348d8bab3411165a40913ee87282acad11473bab (diff)
downloadabslibre-b469fe846f9de0b81022844f8d847e4589a0b9fc.tar.gz
abslibre-b469fe846f9de0b81022844f8d847e4589a0b9fc.tar.bz2
abslibre-b469fe846f9de0b81022844f8d847e4589a0b9fc.zip
Merge ssh://parabolagnulinux.org:1863/abslibre
Diffstat (limited to 'social/uci/PKGBUILD')
-rw-r--r--social/uci/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/social/uci/PKGBUILD b/social/uci/PKGBUILD
new file mode 100644
index 000000000..d306b77bd
--- /dev/null
+++ b/social/uci/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Nicolás Reynolds <fauno@kiwwwi.com.ar>
+pkgname=uci
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="OpenWRT's Unified Configuration Interface"
+arch=('i686' 'mips64el')
+url="https://openwrt.org"
+license=('GPL2')
+makedepends=('git' 'cmake' 'lua')
+source=(http://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}.tar.gz)
+md5sums=('135bf6c4188b72c7fd7954f592b1e4e4')
+
+# source PKGBUILD; mksource
+mksource() {
+
+ if [ -d uci/.git ]; then
+ pushd uci; git pull; popd
+ else
+ git clone git://nbd.name/uci.git
+ fi
+
+ cd uci/
+ git archive --prefix=${pkgname}-${pkgver}/ v${pkgver} | \
+ gzip -9 > ../${pkgname}-${pkgver}.tar.gz
+ cd ..
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ cmake .
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir}/ install
+}
+
+# vim:set ts=2 sw=2 et: