summaryrefslogtreecommitdiff
path: root/social/tokyocabinet/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2011-12-23 13:57:12 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2011-12-23 13:57:12 -0500
commit8b46da37a3d01169292b7982818947a4219e1bec (patch)
tree41af66c556c4cdd42cf0a8512275f38c816eed6a /social/tokyocabinet/PKGBUILD
parent8b024219267fe0dfe3a251ff966af66a1fd23d7b (diff)
parentf7ad7579f473125b44db30248841e2d452f9547e (diff)
downloadabslibre-8b46da37a3d01169292b7982818947a4219e1bec.tar.gz
abslibre-8b46da37a3d01169292b7982818947a4219e1bec.tar.bz2
abslibre-8b46da37a3d01169292b7982818947a4219e1bec.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/abslibre
Diffstat (limited to 'social/tokyocabinet/PKGBUILD')
-rw-r--r--social/tokyocabinet/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/social/tokyocabinet/PKGBUILD b/social/tokyocabinet/PKGBUILD
new file mode 100644
index 000000000..6e9b7969d
--- /dev/null
+++ b/social/tokyocabinet/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mark Foxwell <fastfret79@archlinux.org.uk>
+# Contributor: Nicolas Martyanoff <khaelin@gmail.com>
+
+pkgname=tokyocabinet
+pkgver=1.4.47
+pkgrel=1
+pkgdesc="a modern implementation of DBM"
+arch=('i686' 'x86_64')
+url="http://fallabs.com/tokyocabinet/"
+license=('LGPL')
+makedepends=('gcc>=3.1' 'make' 'pkgconfig')
+depends=('zlib' 'bzip2')
+source=("http://fallabs.com/tokyocabinet/${pkgname}-${pkgver}.tar.gz")
+md5sums=('3d94fe2aebf5d9ff0478ed895bc46fc9')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --enable-off64 --enable-fastest
+ make
+}
+
+# uncomment check routine if needed (can take ~5mins to run check)
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: