summaryrefslogtreecommitdiff
path: root/social/liblockfile/PKGBUILD
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-04-15 18:31:32 -0700
committerJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-04-15 18:31:32 -0700
commitffb3ebbe0c98853f03a79b95cfff0f525df7d1fe (patch)
tree9879cb74f4d2f8ab4652b4277b7f66c212766ab0 /social/liblockfile/PKGBUILD
parent833e63b6728e7fe38ea0e77303623efa6bdef48c (diff)
parentc931fbbe5ae1246b69e2c61452f7c3d7632d98c9 (diff)
downloadabslibre-ffb3ebbe0c98853f03a79b95cfff0f525df7d1fe.tar.gz
abslibre-ffb3ebbe0c98853f03a79b95cfff0f525df7d1fe.tar.bz2
abslibre-ffb3ebbe0c98853f03a79b95cfff0f525df7d1fe.zip
Merge branch 'master' of vparabola:~/projects/abslibre
Conflicts: .gitignore
Diffstat (limited to 'social/liblockfile/PKGBUILD')
-rw-r--r--social/liblockfile/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/social/liblockfile/PKGBUILD b/social/liblockfile/PKGBUILD
new file mode 100644
index 000000000..e3428763c
--- /dev/null
+++ b/social/liblockfile/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Andreas Wagner <Andreas dot Wagner at em dot uni-frankfurt dot de>
+
+pkgname=liblockfile
+pkgver=1.08_4
+pkgrel=1
+pkgdesc="a library with NFS-safe locking functions"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://packages.debian.org/unstable/libs/liblockfile1"
+depends=('glibc')
+makedepends=()
+source=(http://ftp.debian.org/debian/pool/main/libl/$pkgname/${pkgname}_1.08.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/libl/$pkgname/${pkgname}_${pkgver/_/-}.debian.tar.bz2)
+
+build() {
+ cd $startdir/src/$pkgname-1.08
+
+ for p in `cat ../debian/patches/series` ; do
+ patch -p1 < ../debian/patches/$p
+ done
+
+ ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+ make || return 1
+
+ mkdir -p $startdir/pkg/usr/{lib,bin,include,share/man/man1,share/man/man3}
+ make install prefix=$startdir/pkg/usr mandir=$startdir/pkg/usr/share/man || return 1
+}
+
+md5sums=('c24e2dfb4a2aab0263fe5ac1564d305e'
+ '50c0c049d2838704f5720f5fd9eaddac')