summaryrefslogtreecommitdiff
path: root/social/aiccu/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@localhost.localdomain>2012-09-21 23:35:58 -0300
committerAndré Fabian Silva Delgado <andre@localhost.localdomain>2012-09-21 23:35:58 -0300
commitad96a8790b1cf1be80d5b021562a328053fba03c (patch)
tree06f21ec6276dff56ca3e2ce9c42ad3f9d950fffd /social/aiccu/PKGBUILD
parent063cb2e97d16fa097c0ab71c3592e0aff0c75230 (diff)
parent5a3cd0a0fd7e2af356d44aa25f144fe9616b8239 (diff)
downloadabslibre-ad96a8790b1cf1be80d5b021562a328053fba03c.tar.gz
abslibre-ad96a8790b1cf1be80d5b021562a328053fba03c.tar.bz2
abslibre-ad96a8790b1cf1be80d5b021562a328053fba03c.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'social/aiccu/PKGBUILD')
-rw-r--r--social/aiccu/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/social/aiccu/PKGBUILD b/social/aiccu/PKGBUILD
new file mode 100644
index 000000000..5fc4cb086
--- /dev/null
+++ b/social/aiccu/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=aiccu
+pkgver=20070115
+pkgrel=7
+pkgdesc="SixXS Automatic IPv6 Connectivity Client Utility - AICCU"
+arch=('i686' 'x86_64')
+url="http://www.sixxs.net/tools/aiccu/"
+license=('BSD')
+depends=('gnutls' 'iproute2')
+makedepends=('glibc' 'libgpg-error' 'libtasn1' 'libgcrypt' 'zlib')
+backup=(etc/aiccu.conf)
+source=(http://www.sixxs.net/archive/sixxs/aiccu/unix/${pkgname}_${pkgver}.tar.gz
+ aiccu.rc.d)
+md5sums=('c9bcc83644ed788e22a7c3f3d4021350'
+ '9eb63ae132d4835a822ea925c6440b04')
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ sed -i 's|Installing Debian-style init.d||' Makefile
+
+ LDFLAGS="" make
+ make DESTDIR="$pkgdir" install
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -D -m600 doc/aiccu.conf "$pkgdir/etc/aiccu.conf"
+ install -D -m755 "$srcdir/aiccu.rc.d" "$pkgdir/etc/rc.d/aiccu"
+ install -D -m444 doc/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ rm -fr "$pkgdir/etc/init.d"
+}