summaryrefslogtreecommitdiff
path: root/pcr/zeroinstall-injector/PKGBUILD1
diff options
context:
space:
mode:
authorAurélien DESBRIÈRES <aurelien@hackers.camp>2014-06-05 23:20:16 +0200
committerAurélien DESBRIÈRES <aurelien@hackers.camp>2014-06-05 23:20:16 +0200
commit81487584f7178da8175954649aefc35db7a89743 (patch)
tree8d5b8eeab143a445a361dcb401f9607709427108 /pcr/zeroinstall-injector/PKGBUILD1
parenta4c0efd3c07f1d45185800f861d7c8b8fbf3c994 (diff)
downloadabslibre-81487584f7178da8175954649aefc35db7a89743.tar.gz
abslibre-81487584f7178da8175954649aefc35db7a89743.tar.bz2
abslibre-81487584f7178da8175954649aefc35db7a89743.zip
Not working PKGBUILD of zeroinstall-injector
Diffstat (limited to 'pcr/zeroinstall-injector/PKGBUILD1')
-rw-r--r--pcr/zeroinstall-injector/PKGBUILD133
1 files changed, 33 insertions, 0 deletions
diff --git a/pcr/zeroinstall-injector/PKGBUILD1 b/pcr/zeroinstall-injector/PKGBUILD1
new file mode 100644
index 000000000..564c9219f
--- /dev/null
+++ b/pcr/zeroinstall-injector/PKGBUILD1
@@ -0,0 +1,33 @@
+# Contributor (Arch) : Ben Darwin <bcdarwin at gmail>
+# Contributor (Arch) : speps <speps at aur dot archlinux dot org>
+# Contributor (Arch) : Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor (Arch) : Lone_Wolf <lonewolf@xs4all.nl>
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+pkgname=zeroinstall-injector
+_pkgname=0install
+pkgver=2.7
+pkgrel=0
+pkgdesc="A decentralised loosely-coupled secure installation system"
+arch=('i686' 'x86_64')
+url="http://0install.net"
+license=('GPL2' 'LGPL')
+depends=('gringo' 'clasp' 'opam' 'aspcud' 'ocaml' 'ocaml-curl' 'ocaml-extlib' 'ocaml-lwt' 'ocaml-biniou'
+ 'ocaml-ounit' 'ocaml-xmlm' 'ocaml-yojson' 'ocaml-findlib')
+optdepends=('ocaml-lablgtk: provides GUI features'
+ 'ocaml-obus: for DBUS, packagekit, and NetworkManager integration'
+ 'xdg-utils: desktop integration'
+ 'packagekit: packagekit integration')
+install="$pkgname.install"
+source=("http://kent.dl.sourceforge.net/project/zero-install/$_pkgname/2.7/$_pkgname-2.7.tar.bz2"
+ "http://kent.dl.sourceforge.net/project/zero-install/$_pkgname/2.7/$_pkgname-2.7.tar.bz2.sig")
+
+build() {
+ cd $_pkgname-$pkgver
+ make || return 1
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install_home
+}