summaryrefslogtreecommitdiff
path: root/pcr/uci/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-13 14:59:54 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-13 14:59:54 -0200
commite8b48097dda2989e21339d911126a523a1c88156 (patch)
tree81ec82965658c85424ce0c651de98eefa73dab5b /pcr/uci/PKGBUILD
parentc7c97acfa81072f1a9f05a67b2408afd4a15b9a7 (diff)
parent95f573b1ef312568fd101511250475aa38e6270a (diff)
downloadabslibre-e8b48097dda2989e21339d911126a523a1c88156.tar.gz
abslibre-e8b48097dda2989e21339d911126a523a1c88156.tar.bz2
abslibre-e8b48097dda2989e21339d911126a523a1c88156.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/uci/PKGBUILD')
-rw-r--r--pcr/uci/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/pcr/uci/PKGBUILD b/pcr/uci/PKGBUILD
new file mode 100644
index 000000000..41541fa07
--- /dev/null
+++ b/pcr/uci/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Nicolás Reynolds <fauno@kiwwwi.com.ar>
+pkgname=uci
+pkgver=0.8.0
+pkgrel=2
+pkgdesc="OpenWRT's Unified Configuration Interface"
+arch=('i686' 'x86_64' 'mips64el')
+url="https://openwrt.org"
+license=('GPL2')
+makedepends=('git' 'cmake' 'lua51')
+source=(http://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}.tar.gz
+ uci-0.8.0-lua5.1.patch)
+md5sums=('135bf6c4188b72c7fd7954f592b1e4e4'
+ '2c8f4d59b2b7adb990dcaa07e0ed484c')
+
+# source PKGBUILD; mksource
+mksource() {
+
+ if [ -d uci/.git ]; then
+ pushd uci; git pull; popd
+ else
+ git clone git://nbd.name/uci.git
+ fi
+
+ cd uci/
+ git archive --prefix=${pkgname}-${pkgver}/ v${pkgver} | \
+ gzip -9 > ../${pkgname}-${pkgver}.tar.gz
+ cd ..
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np1 -i ${srcdir}/uci-0.8.0-lua5.1.patch
+ cmake .
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir}/ install
+}
+
+# vim:set ts=2 sw=2 et: