summaryrefslogtreecommitdiff
path: root/pcr/ttf-league-gothic/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2020-07-12 06:18:17 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2020-07-12 07:15:25 -0400
commit4a40dd3f4e3553048517246435bab172cd3f58f2 (patch)
treecaa482a9c37bbe4e2beb062f41bf772f40d99ad1 /pcr/ttf-league-gothic/PKGBUILD
parent32d85f370cbadb37ee9a7c77f5a59e3bceb43945 (diff)
downloadabslibre-4a40dd3f4e3553048517246435bab172cd3f58f2.tar.gz
abslibre-4a40dd3f4e3553048517246435bab172cd3f58f2.tar.bz2
abslibre-4a40dd3f4e3553048517246435bab172cd3f58f2.zip
[ttf-league-gothic]: rebuild
Diffstat (limited to 'pcr/ttf-league-gothic/PKGBUILD')
-rw-r--r--pcr/ttf-league-gothic/PKGBUILD43
1 files changed, 23 insertions, 20 deletions
diff --git a/pcr/ttf-league-gothic/PKGBUILD b/pcr/ttf-league-gothic/PKGBUILD
index 3257cd3a6..cc5764a15 100644
--- a/pcr/ttf-league-gothic/PKGBUILD
+++ b/pcr/ttf-league-gothic/PKGBUILD
@@ -1,31 +1,34 @@
+# Maintainer (AUR): Caleb Maclennan <caleb@alerque.com>
# Maintainer (AUR): LightDot <lightdot -a-t- g m a i l>
# Contributor (AUR): samæ <samæ at marvid dot fr>
-# Maintainer (Parabola): Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# Maintainer: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# Contributor: bill-auger <bill-auger@programmer.net>
_fnt_name=league-gothic
-pkgname=ttf-$_fnt_name
+pkgbase=$_fnt_name-font
+pkgname=(otf-$_fnt_name ttf-$_fnt_name)
pkgver=20160215
-pkgrel=2
-pkgdesc="League Gothic is a revival of an old classic, and one of our favorite typefaces, Alternate Gothic #1"
+_sha=e6dce2137410648b2229d5d4717de8c1cd5f9b97
+pkgrel=6
+pkgdesc='A revival of an old classic, Alternate Gothic #1'
arch=('any')
-url="http://theleagueofmoveabletype.com/$_fnt_name"
+url="https://theleagueofmoveabletype.com/$_fnt_name"
license=('custom:OFL')
groups=('lmt-fonts')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
-conflicts=('otf-league-gothic')
-source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/master.zip")
-md5sums=('e19525cac31d325b4604d01e36c9fd6c')
+provides=("$pkgbase")
+source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/$_sha.zip")
+sha256sums=('f4cc4f754568c4d2b70c3b52a6663677656ee88277901efcdf079b40e8158ab1')
-package() {
- install -Dm644 "$srcdir/$_fnt_name"-master/LeagueGothic-CondensedItalic.otf "$pkgdir"/usr/share/fonts/OTF/LeagueGothic-CondensedItalic.otf
- install -Dm644 "$srcdir/$_fnt_name"-master/LeagueGothic-CondensedRegular.otf "$pkgdir"/usr/share/fonts/OTF/LeagueGothic-CondensedRegular.otf
- install -Dm644 "$srcdir/$_fnt_name"-master/LeagueGothic-Italic.otf "$pkgdir"/usr/share/fonts/OTF/LeagueGothic-Italic.otf
- install -Dm644 "$srcdir/$_fnt_name"-master/LeagueGothic-Regular.otf "$pkgdir"/usr/share/fonts/OTF/LeagueGothic-Regular.otf
-
- install -Dm644 "$srcdir/$_fnt_name"-master/webfonts/leaguegothic-condensed-italic-webfont.ttf "$pkgdir"/usr/share/fonts/TTF/LeagueGothic-CondensedItalic.ttf
- install -Dm644 "$srcdir/$_fnt_name"-master/webfonts/leaguegothic-condensed-regular-webfont.ttf "$pkgdir"/usr/share/fonts/TTF/LeagueGothic-CondensedRegular.ttf
- install -Dm644 "$srcdir/$_fnt_name"-master/webfonts/leaguegothic-italic-webfont.ttf "$pkgdir"/usr/share/fonts/TTF/LeagueGothic-Italic.ttf
- install -Dm644 "$srcdir/$_fnt_name"-master/webfonts/leaguegothic-regular-webfont.ttf "$pkgdir"/usr/share/fonts/TTF/LeagueGothic-Regular.ttf
+package_otf-league-gothic() {
+ cd "$_fnt_name-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" *.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open\ Font\ License*.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" readme.markdown
+}
- install -Dm644 "$srcdir/$_fnt_name"-master/Open\ Font\ License.markdown "$pkgdir/usr/share/licenses/$pkgname"/OFL.txt
+package_ttf-league-gothic() {
+ cd "$_fnt_name-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" webfonts/*.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open\ Font\ License*.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" readme.markdown
}