summaryrefslogtreecommitdiff
path: root/pcr/sineshaper/PKGBUILD
diff options
context:
space:
mode:
authorGuest One <theguestone@gmail.com>2013-05-18 23:35:14 +0200
committerGuest One <theguestone@gmail.com>2013-05-18 23:35:14 +0200
commit25209c347b50cd166b5d954a8db4e0b93a20dd19 (patch)
tree8e6f87b3d6558e6277e8875f5bfda1c80f636c78 /pcr/sineshaper/PKGBUILD
parente7d4c166764dc46fa4c83b698f47f40723c43049 (diff)
downloadabslibre-25209c347b50cd166b5d954a8db4e0b93a20dd19.tar.gz
abslibre-25209c347b50cd166b5d954a8db4e0b93a20dd19.tar.bz2
abslibre-25209c347b50cd166b5d954a8db4e0b93a20dd19.zip
added new package sineshaper 0.4.2-1
Diffstat (limited to 'pcr/sineshaper/PKGBUILD')
-rw-r--r--pcr/sineshaper/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/pcr/sineshaper/PKGBUILD b/pcr/sineshaper/PKGBUILD
new file mode 100644
index 000000000..61560a770
--- /dev/null
+++ b/pcr/sineshaper/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer : Guest One <theguestone at gmail dot com>
+# patch taken from https://aur.archlinux.org/packages/sineshaper/
+pkgname=sineshaper
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="A monophonic DSSI synth plugin."
+arch=('i686')
+url="http://www.student.nada.kth.se/~d00-llu/music_dssi.php?lang=en"
+license=('GPL')
+depends=('libglademm' 'dssi')
+makedepends=('ladspa')
+source=("http://ll-plugins.sourceforge.net/release/$pkgname-$pkgver.tar.gz" gcc-4.3.patch)
+md5sums=('952cb5bde0ae4fe2274859df5ed1ee61'
+ '78c44bb7b1586917224f26aaa9545e9e')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # gcc 4.3 patch
+ patch -Np1 -i "$srcdir/${source[1]}"
+
+ # DSO link fix
+ LDFLAGS+="-lgthread-2.0" \
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ # rename launcher
+ mv "$pkgdir/usr/bin/$pkgname.sh" \
+ "$pkgdir/usr/bin/$pkgname"
+}